Last Comment Bug 502202 - modifications to search plugin description files don't get picked up on Windows (editing google.xml manually has no impact)
: modifications to search plugin description files don't get picked up on Windo...
Status: RESOLVED WONTFIX
:
Product: Firefox
Classification: Client Software
Component: Search (show other bugs)
: unspecified
: x86 Windows XP
: -- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Florian Quèze [:florian] [:flo]
Mentors:
: 508712 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-03 05:56 PDT by kinwolf
Modified: 2009-09-02 11:19 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
google.xml file with changed in it as asked for (2.31 KB, text/xml)
2009-07-03 10:47 PDT, kinwolf
no flags Details

Description kinwolf 2009-07-03 05:56:19 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)

After installing firefox 3.5 I wanted to change back my default search to www.google.com/ig so I edited google.xml.  Doing so doesn't work anymore as it seem firefox doesn't read that file after it's initial start.  Someone told me to move then delete google.xml, restart firefox(now google isn't avail anymroe) then close firefox, put back the modified google.xml back in the right folder and restart firefox.  That was the only way to make firefox re-read the xml file.  But I can't believe this behavior is wanted.  

Reproducible: Always

Steps to Reproduce:
1.Modify google.xml to change search page
2.put nothing in the search bar and push "enter".
3.Watch and see that the change is never taken into account
Actual Results:  
the change is never taken into account

Expected Results:  
To get the right search page, that is www.google.com/ig
Comment 1 Henrik Skupin (:whimboo) 2009-07-03 07:06:14 PDT
What have you changed? Please attach the changed file to this bug.
Comment 2 kinwolf 2009-07-03 10:47:27 PDT
Created attachment 386743 [details]
google.xml file with changed in it as asked for
Comment 3 kinwolf 2009-07-03 10:48:10 PDT
I attached the file as requested. The only line changed in it is <SearchForm>http://www.google.com/ig</SearchForm>
Comment 4 :Gavin Sharp [email: gavin@gavinsharp.com] 2009-07-07 08:36:56 PDT
Firefox 3.5 stores engine data in a JSON cache and only reloads the data from the XML files if it detects a change.

We check the directory's lastModifiedTime to determine whether to invalidate the cache, but perhaps that isn't set reliably for file modifications on Windows (I thought we'd tested that?).
Comment 5 Ryan Flint [:rflint] (ping via IRC for reviews) 2009-09-01 18:08:08 PDT
Windows only sets the mtime on the parent directory when the file structure within it changes - other platforms do what you'd expect. We decided that the costs of checking each file every time were far too high to support such a rare use case. As a workaround you can move the file around as you did, or delete search.json from the profile directory.
Comment 6 Ryan Flint [:rflint] (ping via IRC for reviews) 2009-09-01 18:11:02 PDT
*** Bug 508712 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.