Closed Bug 502447 Opened 11 years ago Closed 11 years ago

style.overflow="hidden" followed by style.overflow="" fails to reshow scrollbars

Categories

(Core :: Layout, defect, P2)

x86
Windows XP
defect

Tracking

()

RESOLVED FIXED
mozilla1.9.2a1
Tracking Status
status1.9.2 --- beta1-fixed

People

(Reporter: dao, Assigned: bzbarsky)

References

Details

(Keywords: regression, testcase)

Attachments

(2 files)

Attached file testcase
See attached testcase. The first button sets the root element's style.overflow to "hidden", the second one to "". The scrollbar should reappear but doesn't, although the computed style correctly says "overflow: visible".

Works as expected on 1.9.1.
Flags: blocking1.9.2?
More likely bug 78070.
Assignee: nobody → bzbarsky
Blocks: 78070
Note to self: the problem is that PropagateScrollToViewport sets the viewport's style override to the style of the frame we propagate from, but it happens when constructing frames for the <body>(!), except in debug builds (where it also happens in ConstructDocElementFrame, but after we did the scrollframe setup).  This causes us to pick up the override style of "hidden" when constructing the scrollframe after the second button click, and hence not create any scrollbar frames.
Attached patch Like so, saySplinter Review
Attachment #390057 - Flags: review?(roc)
Pushed http://hg.mozilla.org/mozilla-central/rev/4a3ddae856c7
Status: NEW → RESOLVED
Closed: 11 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Flags: blocking1.9.2? → blocking1.9.2+
Priority: -- → P2
This landed before the 1.9.2 branchpoint.
Keywords: fixed1.9.2
Target Milestone: --- → mozilla1.9.2a1
Depends on: 550882
You need to log in before you can comment on or make changes to this bug.