Bugzilla needs a JSON-RPC client implementation in JS under MPL or compatible

RESOLVED WORKSFORME

Status

()

Bugzilla
User Interface
--
enhancement
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: C.J. Adams-Collier, Assigned: Guy Pyrzak)

Tracking

Details

(Whiteboard: [blocker will fix], URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.11) Gecko/2009060309 Ubuntu/9.04 (jaunty) Firefox/3.0.11
Build Identifier: 

Likely released under MIT/X11 or the Mozilla Public License. I’m looking around to find one. Maybe Mono has one in the AJAX contribution it recently received from Microsoft. It’s licensed under Ms-PL, though, so I don’t know if it qualifies.

--

if all else fails, I'll write one myself.  I hate writing javascript.

Reproducible: Always
(Reporter)

Comment 1

8 years ago
please assign to me.

cjac@colliertech.org

Updated

8 years ago
Severity: normal → enhancement
Version: unspecified → 3.5

Updated

8 years ago
Assignee: ui → cjcollier
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Bugzilla needs a JSON-RPC implementation in JS under MPL or compatible → Bugzilla needs a JSON-RPC client implementation in JS under MPL or compatible
Target Milestone: --- → Bugzilla 3.6

Comment 2

8 years ago
Also, whatever it is should ideally use YUI.
(Assignee)

Comment 3

8 years ago
this implementation should be a subclass of the YUI datasource class. Here is a URL for more info. http://developer.yahoo.com/yui/datasource/
(Assignee)

Comment 4

8 years ago
actually you should use http://developer.yahoo.com/yui/connection/ not datasource

Updated

8 years ago
Assignee: cjac → mkanat
Depends on: 490923
Whiteboard: [blocker will fix]

Comment 5

8 years ago
We no longer accept new features for Bugzilla 3.6. Retargetting to 3.8.
Target Milestone: Bugzilla 3.6 → Bugzilla 3.8

Comment 6

7 years ago
Turns out that we don't really need one anymore; it's simple enough to use JSON-RPC that we don't need a whole client.
Assignee: mkanat → guy.pyrzak
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Target Milestone: Bugzilla 3.8 → ---
You need to log in before you can comment on or make changes to this bug.