Firefox should offer to view .ZIP archives using its jar: protocol handler

RESOLVED WONTFIX

Status

()

enhancement
RESOLVED WONTFIX
10 years ago
4 years ago

People

(Reporter: info, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2a1pre) Gecko/20090704 Minefield/3.6a1pre
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2a1pre) Gecko/20090704 Minefield/3.6a1pre

Firefox can display the contents of .ZIP files using its built-in jar: protocol handler.  But Firefox will not offer to view the  contents of .ZIP files or even .jar files.  You have to know to change a URL like
  http://www.skierpage.com/moz_bugs/simple.myarchive
to
  jar:http://www.skierpage.com/moz_bugs/simple.myarchive!/

Reproducible: Always

Steps to Reproduce:
1.  Browse to remote .ZIP and .jar files.
http://www.skierpage.com/moz_bugs/ has simple.zip (served as application/zip) and simple.myarchive (served as application/java-archive), which you can view and/or save locally.
2.  Browse to local .ZIP and .jar files.

Actual Results:  
Firefox won't offer to let you view the contents, even if the remote file is served with the "application/java-archive" mime type.

Expected Results:  
When you click on a ZIP archive, Firefox should offer to "View archive contents in Firefox" and use its existing jar: protocol handler and jar:<URL>!/ trick to show you the contents.

To view the contents of remote files served as application/zip using the jar:<URL>!/ trick, you have to change network.jar.open-unsafe-types to true in about:config.  I don't know if this should apply if you explicitly choose the new "View archive contents in Firefox" option that I am proposing.

When you save locally, you can always use the jar: trick regardless of extension without needing to change about:config; e.g. if you save a ZIP file as simple.blah in /tmp, then
 jar:file:///tmp/simple.blah!/
works. However, a general "View this file in Firefox as if it were [text/XML/ZIP archive/HTML/OGG]" capability seems like a separate bug.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 64286
The title of Bug 64286 is a wishlist for "web archive save/view support" of dozens of archive formats.  I'm just asking to expose Firefox's existing ability to view ZIP archives.  Doesn't sound like a duplicate to me :-(
Indeed, I meant this one.
Duplicate of bug: 132008
(In reply to comment #3)
> Indeed, I meant this one.
But bug 132008 proposes a wacky new syntax for jar: handling that conflicts with Sun's documented protocol.  So I un-duped this.

Firefox is a compliant JAR file viewer and adequate .ZIP file viewer, yet if I browse to a JAR file, Firefox won't offer to view it.  Feel free to change my summary if it's unclear.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
I try to view content of zip file via line like:

  jar:/usr/share/doc/libboost1.58-doc/examples/libs/python/example/project.zip
  jar:file:///usr/share/doc/libboost1.58-doc/examples/libs/python/example/project.zip

Firefox send that string to Google search.

If except viewing files Firefox also render HTML/JS/CSS/IMG zip file content that would mean that we have CHM alternative!
jar: support will be disabled by default since Firefox 45 which is quite the opposite of this bug:
https://www.fxsitecompat.com/docs/2015/jar-protocol-support-has-been-disabled-by-default/
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.