Last Comment Bug 502584 - Firefox will crash when visiting www.hp.com on sparc platform.
: Firefox will crash when visiting www.hp.com on sparc platform.
Status: RESOLVED FIXED
: crash, verified1.9.1.1
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: Sun Solaris
: -- critical (vote)
: mozilla1.9.2a1
Assigned To: Leon Sha
:
: Jason Orendorff [:jorendorff]
Mentors:
http://www.hp.com
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-06 04:42 PDT by Leon Sha
Modified: 2009-07-15 08:37 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (3.88 KB, patch)
2009-07-06 04:56 PDT, Leon Sha
gal: review+
Details | Diff | Splinter Review

Description Leon Sha 2009-07-06 04:42:27 PDT
Firefox will crash when visiting www.hp.com on Sparc platform.
Comment 1 Leon Sha 2009-07-06 04:56:28 PDT
Created attachment 386970 [details] [diff] [review]
patch

The following code was generated for www.hp.com
..........
sethi    %hi(0xec847000), %l0 
bset     0x00000088, %l0        ! 0xec847088
sethi    %hi(0x1400), %l0
bset     0x000001fc, %l0        ! 0x15fc
st       %l0, [%i0 + %l0]
..........
Register %l0 was recovered by itself.
The reason here is that register L0 is used as a temporary register in a lot of micros. So when these macros are used, L0 should not be used any more. We need other temporary registers. So use L2 to replace L0 in NativeSparc.cpp.
Comment 3 Tony Chung [:tchung] 2009-07-14 08:19:25 PDT
Leon, or anyone with sparc, can you verify this fix on trunk and a 1.9.1 nightly? 
Please change the status to verified and keyword to verified1.9.1.1 also.   Thanks.

Note You need to log in before you can comment on or make changes to this bug.