If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Newly created tab suddenly disappears and a new FF3.5 window opens

VERIFIED DUPLICATE of bug 489729

Status

()

Firefox
Tabbed Browser
VERIFIED DUPLICATE of bug 489729
8 years ago
8 years ago

People

(Reporter: Donald Glass, Unassigned)

Tracking

3.5 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1) Gecko/20090624 Firefox/3.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1) Gecko/20090624 Firefox/3.5

Some time between a few seconds and 5 minutes after creating a new tab, and always while viewing the contents on the Tab, the tab CLOSES and a new FF3.5 session opens - with the same URL of the 'missing tab'.
This has ocurred more than 30 times over the past two days.
Sometimes MORE than one tab closes (on one ocassion FIVE tabs closed) and then a new FF3.5 session opens for EACH closed Tab

Reproducible: Sometimes

Steps to Reproduce:
1.Create New Tab
2.Happens most often when YAHOO search is used to find content
3.Open new URL in this new Tab
4.Approx 1 in 5 ocassions, the tab will close between 2 seconds and 5 mins of the new URL being opened.
Actual Results:  
TAB (or multiple Tabs) on current FF3.5 session CLOSE and a new FF3.5 session 9or multiple sessions) are opened, with the content of these (closed) Tabs.

Expected Results:  
Tabs to REMAIN open as active TABS on the first FF3.5 session
Does this happen in safe mode? Are you sure you are not dragging the tabs out to create new windows?
Version: unspecified → 3.5 Branch
(Reporter)

Comment 2

8 years ago
Not safe mode.
Certainly NOT doing any dragging or other manipulations. (been using FF for over 5 years - on my computer daily).
It has NEVER happened to me before on any previosu version of FF
It has ONLY started to happen after upgrade to FF3.5 and it happend regularly.

Comment 3

8 years ago
So it does not happen in safe mode?  The reason Tyler asked if you are dragging the tabs is because in 3.5 tab tearing is now a feature to create a new window.  If you areclicking the tab and moving your mouse a few pixels down, it will create a new window with that tab loaded
(Reporter)

Comment 4

8 years ago
OK Understand, Thanks.
It HAS now happened in SAFE MODE.
(I've only run in safe mode for a few hours - since Tyler email).
This ocassion I had FOUR tabs open - internet banking being done in tyhe 4th tab.
I was BUSY ENTERING a figure into an open field in the Bank website (Https: site) when the page (tab) suddenly closed ...Woomp!
The page was still open , but in a NEW instance of FF.
I transferred my screen to the NEW FF3.5 instance and carried on with the banking.
(The open URL session was not affected at all).
(Reporter)

Comment 5

8 years ago
Hi Tyler, Kurt & others.
Looked at my notes and realised TWO additional common factors.
1) The 'disappearing tab' problem ONLY occurs when the FF3.5 session has THREE or more tabs... it has NEVER happened with just one or two tabs.
2) ONE of the active tabs - when the problem has occurred - has ALWAYS been "gmail". If gmail is NOT on one of the tabs, then the phenomenon has not occurred.

Comment 6

8 years ago
weird...I ALWAYS have gmail opened in the first tab and I usually have at least 20 tabs open and have not seen this happen once.  I can't even think what could cause this as web pages can not alter the chrome and the only way to tear a tab is to physically move it.

Comment 7

8 years ago
This has been consistently happening to my family members and I. Gmail has not been a factor. It happens when there are three tabs opened and no one is dragging tabs. Firefox will suddenly put one of the tabs into a new window, usually the current open tab. This is EXTREMELY ANNOYING. We will be most grateful if this phenomenon is fixed soon. Thanks!

Updated

8 years ago
Keywords: qawanted

Comment 8

8 years ago
I observed the same problem. It happens with no special site loaded in the tabs and without dragging them.
But even if dragging is the reason, maybe the number of pixels a tab has to be moved before a new window is created could be set to higher value.

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 489729
Status: RESOLVED → VERIFIED
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.