Closed Bug 502634 Opened 10 years ago Closed 10 years ago

ipdlc cannot compile NPP.ipdl

Categories

(Core :: IPC, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: benjamin, Assigned: cjones)

Details

trying to compile NPP.ipdl:

  File "/builds/electrolysis/src/ipc/ipdl/ipdl/type.py", line 509, in visitMessageDecl
    if decl is not None and decl.type.isProtocol():
AttributeError: MessageType instance has no attribute 'isProtocol'

decl.type is None. I tried adding a null-check and it failed in a similar way with some type that didn't implement isProtocol. Since I'm not sure what I'm doing, I'm just going to file this and leave it for cjones.
I can't reproduce this.  Can you provide the exact command you ran?  I tried

  dom/plugins $ ../../ipc/ipdl/ipdlc NPP.ipdl

and that works fine.
Hrm, this was with a fixed up patch from bug 502003

python ipc/ipdl/ipdl.py dom/plugins/NPP.ipdl dom/plugins/NPAPI.ipdl

Is it possible that compiling multiple protocols is causing problems somehow?
Pushed
62eedc3a5f90 Chris Jones - bugs 502003, 502634: compile multiple IPDL specs in one invocation
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
QA Contact: ipc
You need to log in before you can comment on or make changes to this bug.