Firefox 3.5 always hangs at startup waiting for futex/pthred_mutex_lock

RESOLVED DUPLICATE of bug 435683

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 435683
9 years ago
8 years ago

People

(Reporter: Andrea Mazzoleni, Unassigned)

Tracking

({hang})

3.5 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.11) Gecko/2009060214 Firefox/3.0.11
Build Identifier: http://www.mozilla.com/products/download.html?product=firefox-3.5&os=linux&lang=en-US

Firefox 3.5 simply never starts, and it hangs forever.

Nothing is displayed. CPU is not used.



Reproducible: Always

Steps to Reproduce:
1 Start firefox

Actual Results:  
It hangs.

Expected Results:  
It starts.

Running with Linux Slackware 12.2.
No problem running Firefox 3.0.x.

The end of "strace -f ./firefox" is:
[pid 16232] mprotect(0xb6a32000, 12288, PROT_READ) = 0
[pid 16232] mprotect(0xb6a62000, 4096, PROT_READ) = 0
[pid 16232] mprotect(0xb71d7000, 4096, PROT_READ) = 0
[pid 16232] mprotect(0xb8074000, 4096, PROT_READ) = 0
[pid 16232] mprotect(0xb80c7000, 4096, PROT_READ) = 0
[pid 16232] munmap(0xb8078000, 178741)  = 0
[pid 16232] set_tid_address(0xb63a3718) = 16232
[pid 16232] set_robust_list(0xb63a3720, 0xc) = 0
[pid 16232] futex(0xbfcc6130, 0x81 /* FUTEX_??? */, 1) = 0
[pid 16232] futex(0xb71d8070, 0x81 /* FUTEX_??? */, 2147483647) = 0
[pid 16232] open("/proc/cpuinfo", O_RDONLY) = 3
[pid 16232] read(3, "processor\t: 0\nvendor_id\t: Genuin"..., 1024) = 472
[pid 16232] read(3, "", 1024)           = 0
[pid 16232] close(3)                    = 0
[pid 16232] futex(0x8056bc0, 0x80 /* FUTEX_??? */, 2 <unfinished ...>

The backtrace from the debugger "./run-mozilla.sh -g firefox-bin" 
after a manual SIGINT is:

Program received signal SIGINT, Interrupt.
[Switching to Thread 0xb62db6d0 (LWP 17357)]
0xb7fa4f74 in __lll_lock_wait () from /lib/libpthread.so.0
(gdb) bt
#0  0xb7fa4f74 in __lll_lock_wait () from /lib/libpthread.so.0
#1  0xb7fa0878 in _L_lock_95 () from /lib/libpthread.so.0
#2  0xb7fa026a in pthread_mutex_lock () from /lib/libpthread.so.0
#3  0x0804f79b in ?? ()
#4  0x08056bc0 in ?? ()
#5  0x00000000 in ?? ()
(Reporter)

Comment 1

9 years ago
Some users are reporting the same problem (same strace result) in the forum:

http://support.mozilla.com/tiki-view_forum_thread.php?locale=de&forumId=1&comments_parentId=379151
(Reporter)

Updated

9 years ago
Version: unspecified → 3.5 Branch
Blocks: 479078
Keywords: hang

Comment 2

9 years ago
Does it happen in safe mode? (http://support.mozilla.com/en-US/kb/Safe+Mode)

I've seen in the past some extensions deadlocking Firefox.
(Reporter)

Comment 3

9 years ago
It happens also in SafeMode. Sorry for not mention that.

I tried also deleting the directories ~/.mozilla and /usr/lib/mozilla
but the problem still persist.
Here are the source references to /proc/cpuinfo
http://mxr.mozilla.org/mozilla1.9.1/search?string=proc%2Fcpuinfo&find=%5C.c&findi=&filter=%5E%5B%5E%5C0%5D*%24&hitlimit=&tree=mozilla1.9.1
pthread_mutex_lock calls:
http://mxr.mozilla.org/mozilla1.9.1/search?string=pthread_mutex_lock&find=%5C.c&findi=&filter=%5E%5B%5E%5C0%5D*%24&hitlimit=&tree=mozilla1.9.1
The file that accesses /proc/cpuinfo and does pthread_mutex_lock calls 
is jemalloc.c
(Reporter)

Comment 7

9 years ago
Anyone know where can I download a binary of firefox 3.5 with DEBUG info ?

In that way I could provide a better stack trace

Comment 8

9 years ago
Mozilla doesn't publish debug builds on Linux, because they would be too large (hundreds of MB).

Some distributions provide packages with debug symbols. If Slackware doesn't, the best option is to compile it yourself. You can find the instructions on https://developer.mozilla.org/En/Simple_build

Comment 9

9 years ago
Same problem for me with slackware-current.
This looks like bug #435683. Are people experiencing this using aoss, libsafe or similar utilities that divert open() ? Is it still freezing if you run LD_PRELOAD=/lib/libc.so.6 firefox ?

Comment 11

9 years ago
(In reply to comment #10)
> Is it still freezing if you run
> LD_PRELOAD=/lib/libc.so.6 firefox ?

No, it is not freezing when I run with the LD_PRELOAD workaround.  This bug might indeed be a dup, I say, typing this on FF3.5...
(Reporter)

Comment 12

9 years ago
Also here (slackware 12.2) the LD_PRELOAD trick works!
(Reporter)

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 435683
You need to log in before you can comment on or make changes to this bug.