Changing a dropdown selected="selected" does not change on page refresh

RESOLVED DUPLICATE of bug 46845

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 46845
8 years ago
8 years ago

People

(Reporter: DougS, Unassigned)

Tracking

3.5 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

224 bytes, text/html
Details
(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)

In an html dropdown list where an item is default selected, if the default selected item is changed to another item, a refresh of the page does not show the change.

<select size="1">
	<option value="CA" selected="selected">California</option>
	<option value="AR" >Arkansas</option>
	<option value="AZ">Arizona</option>
</select>

Make AR the selected option and California still remains the selected item on a refresh.(CTRL-R)

Reproducible: Always

Steps to Reproduce:
1.Create <select> list with 3 options
2.Make first option selected. View page. First option is selected.
3.Change selected="selected" to second option. View Page and refresh. First option is still selected.


Expected Results:  
The second option should become the selected option in the dropdown.
(Reporter)

Updated

8 years ago
Version: unspecified → 3.5 Branch

Comment 1

8 years ago
Created attachment 387444 [details]
testcase
Regular refresh preserves current form values (including current selection).  Note that if you'd changed from the selected option to something else and refreshed the something else would be selected after the refresh.

It also preserves lots of other information (scroll position, etc).

If you want to refresh while throwing away all cached information, use Ctrl+Shift+R.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 46845
(Reporter)

Comment 3

8 years ago
I wasn't clear on this bug, I guess. I'm looking at this as a programmer who changes the default value of the dropdown on my html page from one selection to another selection programmatically. I am NOT reporting this as a user selecting from a dropdown. 

If I change the default selection in my html code and refresh the page, I should see the change in the dropdown, but I don't in FF3.5. Looking at the code from a FF page, I see that the default selection code has changed, but the DISPLAY of the change on the page, i.e. Arizona changing to California (Arizona being my initial default and Calif being my new default), does not change. Nothing is shown as default or Ariz is still shown as default. This is what is wrong. 

This is also not a duplicate of 46845 because that bug was strictly from the user's end of things where you want to preserve selected data from a page.

Doug
(Reporter)

Comment 4

8 years ago
The only way to make the default selection show is to close the FF window, open a new window and load the page again. Then the new default selection will display as the default as it should.

Not sure what else I can say except it is not resolved.

Doug
We don't differentiate between the user changing the selection and the script changing it (probably in response to something the user did).
You need to log in before you can comment on or make changes to this bug.