[HTML5] CDATA escapes need to close after --\s*!>

RESOLVED DUPLICATE of bug 503632

Status

()

Core
HTML: Parser
P1
major
RESOLVED DUPLICATE of bug 503632
9 years ago
8 years ago

People

(Reporter: -fullmetaljacket-, Unassigned)

Tracking

({testcase})

Trunk
testcase
Points:
---
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

134 bytes, text/html
Details
(Reporter)

Description

9 years ago
http://www.erc.gov.ph/

the url above does not load (empty white page) when html5 parser is turned on.

Comment 1

9 years ago
Fishy comments in the script

From the source code of that page:

<script language="JavaScript">

<!-- hide script from old browsers
// Script to create a drop-down menu effect using layers.
//(c)Copyright Daren Craddock 2002
//You may use this code in any application, no limits,
//provided that you acknowledge Daren Craddock as the originator.
// big() makes selected layer longer (height property)

removing the first line allows the page to load.
The problem is -- !>. Need to escalate this as a spec issue.
Already landed. Not blocking the landing.
No longer blocks: 487949
Summary: [HTML5] website does not load when html5 parser is enabled → [HTML5] CDATA escapes need to close after --!\s*>
Spec bug:
http://www.w3.org/Bugs/Public/show_bug.cgi?id=7089
Summary: [HTML5] CDATA escapes need to close after --!\s*> → [HTML5] CDATA escapes need to close after --\s*!>
(Reporter)

Updated

9 years ago
OS: Windows 7 → All
Hardware: x86 → All
Need a regression test here too.
Flags: in-testsuite?
(Reporter)

Updated

9 years ago
Blocks: 373864
(Reporter)

Comment 6

9 years ago
Created attachment 389404 [details]
testcase
(Reporter)

Updated

9 years ago
Keywords: testcase
Note for anyone searching for duplicates:
If you've seen this in the wild elsewhere, please note the URL here.
Comment on attachment 389404 [details]
testcase

The test case tests comments rather than CDATA escapes.
Attachment #389404 - Attachment is obsolete: true
Priority: -- → P1
Fixed by the fix for bug 503632 even though not strictly a dupe.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 503632
(Reporter)

Comment 11

8 years ago
verified fixed by bug 503632 using testcase posted
You need to log in before you can comment on or make changes to this bug.