[HTML5] Self-closing tags show as error in view-source (even with new parser)

RESOLVED FIXED in mozilla10

Status

()

Core
HTML: Parser
P3
normal
RESOLVED FIXED
8 years ago
6 years ago

People

(Reporter: PikeUK, Unassigned)

Tracking

Trunk
mozilla10
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
HTML5 self-closing tags show as error in view-source (even with new parser)

Steps to Reproduce
1. Set html5.enable to true in about:config, restart Firefox.
2. View source on the following HTML5 validating page: http://ejohn.org/

Actual Behaviour
Self-closing tags are marked as errors.

Expected Behaviour
Self-closing tags are not marked as errors due to item 6 here:
http://www.w3.org/TR/html5/syntax.html#start-tags

Sorry if this is a misunderstanding on my part, I thought it was better to report it on the (no doubt slim) off-chance that it really is a bug.
Depends on: 482921
Henri, we don't use the new parser for view-source, right?
We don't. Need to remember this when fixing bug 482921.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Fixed by fixing bug 482921.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla10
You need to log in before you can comment on or make changes to this bug.