FF 3.5 HTML5 audio controller shows video loading symbol on page load/reload

RESOLVED DUPLICATE of bug 538084

Status

()

Toolkit
Video/Audio Controls
RESOLVED DUPLICATE of bug 538084
9 years ago
8 years ago

People

(Reporter: Steven Rowat, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5

Because of the slider-knob-disappearing bug 502892 it's necessary to set the height of the audio tag to 80px or more. Unfortunately this causes that area above the audio controller to flash with the 'video loading' symbol on page refresh, which is annoying and confusing (to the user), since there is in fact no video coming; this is an audio tag after all and there's only going to be audio.

Perhaps this behavior is related to bug 497666; Ffox does appear to be treating the audio tag as if it's a video tag. For example, if I change the tag to 'video/video', it behaves exactly the same, in all respects that I can determine.

Reproducible: Always

Steps to Reproduce:
1.set audio tag in FF3.5 with ogg vorbis audio file, using 'source' element, [and in my code there is a second 'source' to carry an .mp3 file for Safari, which is likely unrelated, since FF is ignoring that.].
2.Set height of audio tag to 80px (so controller slider knob will be visible).
3.Refresh page. 
Actual Results:  
Flash of video loading symbol.

Note that this loading symbol can also occasionally be forced by moving the time balloon, which is very likely part of this same bug.
Component: General → Video/Audio
Product: Firefox → Core
QA Contact: general → video.audio
Version: unspecified → 1.9.1 Branch
(Reporter)

Updated

9 years ago
Summary: FF 3.5 HTML5 audio controller shows video loading symbol on page reload → FF 3.5 HTML5 audio controller shows video loading symbol on page load/reload
Component: Video/Audio → Video/Audio Controls
Product: Core → Toolkit
QA Contact: video.audio → video.audio
Version: 1.9.1 Branch → unspecified

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 538084

Comment 2

8 years ago
Not exactly a dup, but closely related.
Bug 538084 regressed with Gecko 1.9.3 (Fx4).
You need to log in before you can comment on or make changes to this bug.