TM: Trace calling a user-attached function to RegExp

RESOLVED FIXED in mozilla1.9.2a1

Status

()

Core
JavaScript Engine
P2
normal
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: dmandelin, Assigned: brendan)

Tracking

Trunk
mozilla1.9.2a1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed-in-tracemonkey)

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
Created attachment 387746 [details]
Test case

The attached test case doesn't trace. Output:

foo
foo
abort: 11653: callee is not an object
Abort recording of tree /tmp/callprop.js:6@34 at /tmp/callprop.js:7@38: callprop.
foo
foo
foo

It *does* trace if I attach the function to Object.prototype instead. It may have something to do with specialness of the RegExp prototype, but I don't know. What is clear is that the result of test_property_cache is not an object (presumably it is a property or slot instead), and the tracer doesn't support that yet.
(Assignee)

Comment 1

8 years ago
Created attachment 387755 [details] [diff] [review]
fix
Assignee: general → brendan
Status: NEW → ASSIGNED
Attachment #387755 - Flags: review?(mrbkap)
(Assignee)

Comment 2

8 years ago
This is a patch against m-c. I'm gonna disown the bug if I can't check in there.

/be
Priority: -- → P2
Target Milestone: --- → mozilla1.9.2a1

Comment 3

8 years ago
looks ok to take on m-c to me
Comment on attachment 387755 [details] [diff] [review]
fix

want-getters-and-setters!
Attachment #387755 - Flags: review?(mrbkap) → review+
(Assignee)

Comment 5

8 years ago
http://hg.mozilla.org/tracemonkey/rev/49fed67a8067
http://hg.mozilla.org/mozilla-central/rev/a94b39c8f546

/be
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Whiteboard: fixed-in-tracemonkey
Could this have caused the 3.23% Dromaeo regression pointed to here: http://groups.google.com/group/mozilla.dev.tree-management/msg/7344f39035b7a9f7 ?

Comment 7

8 years ago
http://hg.mozilla.org/mozilla-central/rev/49fed67a8067
(Assignee)

Comment 8

8 years ago
(In reply to comment #6)
> Could this have caused the 3.23% Dromaeo regression pointed to here:
> http://groups.google.com/group/mozilla.dev.tree-management/msg/7344f39035b7a9f7
> ?

Jorendorff had some experience with Dromaeo noise jumps lately. I don't see how the patch could slow anything down. What's the chart like since then?

/be
You need to log in before you can comment on or make changes to this bug.