Closed Bug 503417 Opened 12 years ago Closed 12 years ago

message search and Saved searches with tags broken (mozmill test_verify_saved_mail_view (test-mail-views.js) fails)

Categories

(MailNews Core :: Search, defect)

defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b3

People

(Reporter: rain1, Assigned: rkent)

References

Details

(Keywords: regression)

Attachments

(1 file)

I've been seeing this test fail for the past few days. I haven't looked into why it's failing.
Flags: blocking-thunderbird3?
If I create a saved search based on the tag, I don't see any messages in it.
Severity: normal → major
Summary: Mozmill test_verify_saved_mail_view (test-mail-views.js) fails → Saved searches with tags broken (mozmill test_verify_saved_mail_view (test-mail-views.js) fails)
Flags: blocking-thunderbird3? → blocking-thunderbird3+
Target Milestone: --- → Thunderbird 3.0b3
Assignee: nobody → sid.bugzilla
Whiteboard: [needs regressionwindow, patch, review]
0707 works, 0708 fails - message search fails, doesn't need to be a saved search

interesting is that an existing saved search folder with online option enabled doesn't just come up empty, i.e. it has the previous last search results.  so it must not be running the search *at all*
Summary: Saved searches with tags broken (mozmill test_verify_saved_mail_view (test-mail-views.js) fails) → message search and Saved searches with tags broken (mozmill test_verify_saved_mail_view (test-mail-views.js) fails)
Whiteboard: [needs regressionwindow, patch, review] → [patch, review]
perhaps Bug 495519
Blocks: 495519
Whiteboard: [patch, review] → [need patch, review]
This is some sort of editor problem, the search term is not being saved correctly. Yes bug 495519 is a likely suspect. Sid0 took the assignment, but I will look at it as well.
Yep, my bad. Here's the fix. This must go into TB3.0 b3/ SM 2.0 b1
Assignee: sid.bugzilla → kent
Status: NEW → ASSIGNED
Attachment #388002 - Flags: superreview?(neil)
Attachment #388002 - Flags: review?(neil)
Component: Folder and Message Lists → Search
Product: Thunderbird → MailNews Core
QA Contact: folders-message-lists → search
Whiteboard: [need patch, review] → [needs r/sr Neil]
Attachment #388002 - Flags: superreview?(neil)
Attachment #388002 - Flags: superreview+
Attachment #388002 - Flags: review?(neil)
Attachment #388002 - Flags: review+
What needs to be done to get TB 3.0 beta 3 and SM 2.0 beta 1 checkin approval?
Comment on attachment 388002 [details] [diff] [review]
Get attribute and value right in searchvalue

It already has approval for Tb3.0b3 -- asking for SM approval now.
Attachment #388002 - Flags: approval-seamonkey2.0b1?
Attachment #388002 - Flags: approval-seamonkey2.0b1? → approval-seamonkey2.0b1+
Pushed to c-c: http://hg.mozilla.org/comm-central/rev/c5192d9f86c2
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Whiteboard: [needs r/sr Neil]
Duplicate of this bug: 503521
You need to log in before you can comment on or make changes to this bug.