Closed Bug 503503 Opened 12 years ago Closed 12 years ago

Bookmarks on toolbar now hidden have to access with >>

Categories

(Firefox :: Bookmarks & History, defect)

x86
Windows Vista
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 447571

People

(Reporter: keith_worden, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.1) Gecko/20090624 Firefox/3.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.1) Gecko/20090624 Firefox/3.5

To maximize my screen space, on my menu bar I have (in this order) the menu, the bookmark items (one item), the navigation arrow buttons (forward/back) and the location input field. In Firefox 3.0 the my bookmark item button (immediately to the right of the menu Help item) always appeared. In Firefox 3.5 it never appears - instead I get the >> symbol to drop a menu to then see it. If I customize the toolbars and just ok the dialog my bookmark button appears and I don't get the drop >> symbol. If I resize the window and then maximize it the button disappears and >> appears again. The point of putting it there was so I could access one website with one click; now it takes two.


Reproducible: Always

Steps to Reproduce:
1. Have one item only on the bookmarks toolbar.
2. Customize toolbars.
3. Drag "bookmarks toolbar items" from the bookmark toolbar to right of the Help menu item.
4. End customize - bookmarked item appears ok.
5. Resize the Firefox window - bookmarked item replaced by >> drop menu.
6. Customize and ok with no changes.
7. Bookmarked item appears again and >> drop menu disappears.



Tested using the default theme.
This sounds like bug 447571. What's puzzling is that you see a difference between 3.0 and 3.5 - bug 447571 has existed for a while. Are you using a different theme or something?
The problem was different in 3.0.  In 3.0 you would only see the problem if you resized/shrunk the window small enough.  Whereas in 3.5 it happens more often including at startup.  
I noted that in Bug 447571 comment #3.
Gavin, iirc bug 447571 exists only on 3.5 and trunk, not in 3.0 (or  at least not so problematic if it exists at all), afaik
Yes it does sound like 447571, but I never had the problem in 3.0 (used all versions up to 3.0.11), was an immediate and obvious difference in 3.5.
(In reply to comment #3)
> Gavin, iirc bug 447571 exists only on 3.5 and trunk, not in 3.0 (or  at least
> not so problematic if it exists at all), afaik

Hmm, thought it affected 3.0 as well, but I guess I was wrong!
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 447571
You need to log in before you can comment on or make changes to this bug.