The default bug view has changed. See this FAQ.

Update info should allow more html tags through

RESOLVED FIXED

Status

()

Toolkit
Add-ons Manager
--
enhancement
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: Wladimir Palant, Assigned: mossop)

Tracking

({dev-doc-complete, verified1.9.2})

Trunk
dev-doc-complete, verified1.9.2
Points:
---

Firefox Tracking Flags

(status1.9.2 .2-fixed, status1.9.1 .9-fixed)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

8 years ago
I tried to show a fairly simple update info for Adblock Plus development builds - list of change descriptions with the corresponding dates. First attempt was with dictionary lists - dl/dt/dd. Result was a blank page. After consulting updateinfo.xsl I tried a plain list with two paragraphs per list item - no success again. The br tag isn't allowed either so displaying more than one line per list item is out of question. In the end I had to give up on lists altogether, would be nice to have a little more flexibility here however.
(Assignee)

Updated

7 years ago
Duplicate of this bug: 534646
(Assignee)

Updated

7 years ago
Assignee: nobody → dtownsend
Status: NEW → ASSIGNED
Summary: Update info should allow dl/dt/dd and br tags → Update info should allow more html tags through
Blocks: 540968
(Assignee)

Comment 2

7 years ago
Created attachment 422650 [details] [diff] [review]
patch rev 1

This is a first WIP. It removes a lot of the context based restrictions that currently exist and allow html to be formed pretty much anyway we like. Any elements not included in the list for specific actions are stripped but their contents are still included in the display. A set of formatting, block formatting and list formatting tags are allowed to pass through (with all attributes stripped). <br> and <hr> elements are passed through but their contents are ignored. <head>, <style> and <script> are completely stripped because they normally contain various text contents that aren't meant to be human readable.
(Reporter)

Comment 3

7 years ago
Comparing with http://addons.songbirdnest.com/formatting-help.html - xhtml:u is missing as allowed inline element. Also, it would be nice to support xhtml:a but that's not just a matter of templates of course, link clicks need to be handled. As to AMO, they allow xhtml:abbr/xhtml:acronym with title attribute.
(Assignee)

Comment 4

7 years ago
<u> I can add to the list. I intentionally left <abbr> and <acronym> out since I think allowing tooltips here would probably violate our need to avoid UI spoofing. We cannot support anchors right now for technical reasonsthat will hopefully be solved in a future release of Firefox.
(Assignee)

Comment 5

7 years ago
Created attachment 424339 [details]
screenshot

Dan, I'd like your quick approval on this. It is a screenshot showing the new range of formatting available to add-ons in the update information and I'd just like to confirm that you see no issues with what we're allowing them to do with this change.
Attachment #424339 - Flags: review?(dveditz)
Comment on attachment 424339 [details]
screenshot

r=dveditz
Attachment #424339 - Flags: review?(dveditz) → review+
(Assignee)

Comment 7

7 years ago
Created attachment 429022 [details] [diff] [review]
patch rev 2

This is the patch that implements the changes shown.
Attachment #422650 - Attachment is obsolete: true
Attachment #429022 - Flags: review?(robert.bugzilla)
(Assignee)

Comment 8

7 years ago
The test extension at https://people.mozilla.com/~dtownsend/testcases/bug503505/test.xpi was the one used to generate the screenshot.
Attachment #429022 - Flags: review?(robert.bugzilla) → review+
(Assignee)

Comment 9

7 years ago
Landed: http://hg.mozilla.org/mozilla-central/rev/fe2240e4d3d3
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Whiteboard: [needs baking]

Updated

7 years ago
Keywords: dev-doc-needed
(Assignee)

Comment 10

7 years ago
Updated https://developer.mozilla.org/en/Extension_Versioning,_Update_and_Compatibility#Formatting_in_Firefox_3.7_and_later
Keywords: dev-doc-needed → dev-doc-complete
(Assignee)

Comment 11

7 years ago
Comment on attachment 429022 [details] [diff] [review]
patch rev 2

Backporting this to the branches would really help add-on developers and the AMO team.
Attachment #429022 - Flags: approval1.9.2.2?
Attachment #429022 - Flags: approval1.9.1.9?
(Assignee)

Updated

7 years ago
Whiteboard: [needs baking]
Comment on attachment 429022 [details] [diff] [review]
patch rev 2

a=beltzner for both branches
Attachment #429022 - Flags: approval1.9.2.2?
Attachment #429022 - Flags: approval1.9.2.2+
Attachment #429022 - Flags: approval1.9.1.9?
Attachment #429022 - Flags: approval1.9.1.9+
(Assignee)

Comment 13

7 years ago
Pushed to branches:
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/e57b100b52a2
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/a32418a10626
status1.9.1: --- → .9-fixed
status1.9.2: --- → .2-fixed
verified with: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.3pre) Gecko/20100319 Namoroka/3.6.3pre
Keywords: verified1.9.2
You need to log in before you can comment on or make changes to this bug.