If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Fraud report not working properly with JavaScript turned off

VERIFIED FIXED

Status

www.mozilla.org
General
--
minor
VERIFIED FIXED
8 years ago
5 years ago

People

(Reporter: aryx, Assigned: abuchanan)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

If someone visits http://www.mozilla.com/en-US/legal/fraud-report/ with Javascript turned off,
1) he won't see the recaptcha
2) pressing the submit button will show the result of a php var_dump of the values he entered into the form.
Assignee: nobody → buchanae
Summary: Fraud report not working properly with Javascript turned off → Fraud report not working properly with JavaScript turned off
(Assignee)

Comment 1

8 years ago
Thanks, looking at this now.

I'm getting inconsistent results.  Sometimes I can reproduce both #1 and #2, sometimes not.

Here is a screenshot of the Recaptcha working without JS just a minute ago,
http://www.grabup.com/uploads/9a7467a3aff7569a3caa15615ca7c5f9.png

r29743 removes the var_dump.
(Assignee)

Comment 2

8 years ago
r29653 tags the var_dump removal for production.  (Along with a minor change that was in the queue for bug 484989, apparently)

Reed, could you svn up the fraud report survey handler please?

Archaeopteryx, I'm not sure there is anything to fix for issue #1.  I've seen the problem inconsistently (currently I can't reproduce) and it was nothing that a shift+reload couldn't fix.
(Assignee)

Comment 3

8 years ago
just tested with no JS, worked fine.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
verified fixed on http://www.mozilla.com/en-US/legal/fraud-report/
Status: RESOLVED → VERIFIED
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.