KB Article:Crash signature - nsStyleSet::FileRules(int (*)(nsIStyleRuleProcessor*, void*), RuleProcessorData*)

VERIFIED FIXED

Status

support.mozilla.org
Knowledge Base Articles
--
major
VERIFIED FIXED
9 years ago
8 years ago

People

(Reporter: cilias, Assigned: Bo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
I'm not sure of the cause or solution, so the article name is up in the air;
but @ nsStyleSet::FileRules(int (*)(nsIStyleRuleProcessor*, void*), RuleProcessorData*) is a top crash.
The crash bug is bug 492675.

Comment 1

9 years ago
Current guesses are it's related to the MyWebSearch Toolbar which is spyware and also called ASK toolbar or Zone alarm toolbar, see also bug 466024.  But I asked for more QA so we'll be able to confirm that.
(Reporter)

Updated

8 years ago
Severity: normal → major
(Reporter)

Comment 2

8 years ago
Notes for article:
- the issue is under investigation
- most likely caused by ask toolbar or mywebsearch
Summary: User-doc for crashsig: @ nsStyleSet::FileRules(int (*)(nsIStyleRuleProcessor*, void*), RuleProcessorData*) → KB Article:Crash signature - @ nsStyleSet::FileRules(int (*)(nsIStyleRuleProcessor*, void*), RuleProcessorData*)
(Assignee)

Comment 3

8 years ago
Draft is up, ready for review.

I left all of the symbol craziness out of the URL for this one, add back what won't cause problems please.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
QA Contact: kb-articles → bbayles
Resolution: --- → FIXED
(Reporter)

Comment 4

8 years ago
Reviewed and moved KB at:
Wed 19 of Aug, 2009 23:56 EST
Assignee: nobody → bbayles
Status: RESOLVED → VERIFIED
QA Contact: bbayles → kb-articles
(Reporter)

Updated

8 years ago
Summary: KB Article:Crash signature - @ nsStyleSet::FileRules(int (*)(nsIStyleRuleProcessor*, void*), RuleProcessorData*) → KB Article:Crash signature - nsStyleSet::FileRules(int (*)(nsIStyleRuleProcessor*, void*), RuleProcessorData*)

Comment 5

8 years ago
special characters break tiki.  https://support.mozilla.com/en-US/kb/Crash+signature+-+nsStyleSet+FileRules
You need to log in before you can comment on or make changes to this bug.