<tree> pan is buggy with panning feedback enabled

RESOLVED DUPLICATE of bug 503541

Status

()

RESOLVED DUPLICATE of bug 503541
9 years ago
9 years ago

People

(Reporter: Felipe, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
With the touch panning feedback patch applied (bug 485101), a <tree> (and possibly other elements that doesn't support pixel scrolling) doesn't pan correctly: a pan only scrolls one or two elements and instantly trigger the feedback.
(Reporter)

Comment 1

9 years ago
Just as an update, I'm still investigating this problem but I don't have a definite answer yet. From what I've seen so far, it _looks_ like that the tree reports incompatible values for the scroll delta when it is scrolling. The thing is that the problem is triggered on the nsWinGesture.UpdatePanFeedbackY, but it is not clear if this function introduced the bug or if it was always there but it is only manifesting now.
(Reporter)

Comment 2

9 years ago
Fixed in bug 503541
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 503541
(Reporter)

Updated

9 years ago
Blocks: 548100
You need to log in before you can comment on or make changes to this bug.