With https : If you put a '.' at the end of the hostname in the url, the certificate will never match

RESOLVED DUPLICATE of bug 134402

Status

NSS
Libraries
RESOLVED DUPLICATE of bug 134402
8 years ago
4 years ago

People

(Reporter: dev-spider, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1) Gecko/20090624 Firefox/3.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1) Gecko/20090624 Firefox/3.5

https://bugzilla.mozilla.org./ will gives you a 'bad certificate' in this sample there is an other 'bug', 
1) the certificate doesn't match ( he doesn't like the . at the end )
2) but on this website the certificate didn't match with 'dyna-bugzilla.nslb.sj.mozilla.com'  why this name ... it's the reverse lookup of the ip 63.245.209.72 who is the resolution of bugzilla.mozilla.org

Reproducible: Always

Steps to Reproduce:
https://bugzilla.mozilla.org./ => https://<website address>./
Actual Results:  
Bad certificate

Expected Results:  
Good certificate
Assignee: nobody → nobody
Component: Phishing Protection → Libraries
OS: Windows XP → All
Product: Firefox → NSS
QA Contact: phishing.protection → libraries
Hardware: x86 → All
Whiteboard: DUPEME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 466355
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 134402

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.