[quirks]Text that's bold and underlined is handled wrong

RESOLVED FIXED

Status

()

defect
P3
normal
RESOLVED FIXED
19 years ago
4 years ago

People

(Reporter: heejaf, Unassigned)

Tracking

Trunk
x86
Windows 98
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(2 attachments)

Reporter

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)
BuildID:    2000082513

The way the Mozilla handles bold text that is underlined is wrong. Bold text 
that is underlined has a thicker underline, making many sites look really bad. 

Although this may not sound so bad at first, it's really worse you think. 

Lets say there is an underlined text string with only parts of it in bold. Only 
the parts that are in bold will have a thicker underline, the rest of the text 
will have a normal under. This is just plain weird to look at.

It's seems to me the best solution is to make the underline for bold and normal 
text the same (meaning = not so freaking thick)

PS I'm attaching a screenshot of the problem. I'm also attaching the relevant 
html code.

Reproducible: Always
Steps to Reproduce:
Open the html file I'm attachine.					

Actual Results:  Look at the screenshot					

Expected Results:  The underline should be the same
Reporter

Comment 2

19 years ago

*** This bug has been marked as a duplicate of 1777 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE

Comment 4

19 years ago
vrfy dup
Status: RESOLVED → VERIFIED

Comment 5

16 years ago
This is definitely still happening with the testcase supplied here in BuildID
2003100904 yet the testcase for bug 1777 still works so this was incorrectly
duped it seems -> Reopening
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 6

16 years ago
Confirming
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

16 years ago
This was not just dup'ed falsely but it's a regression because I can hardly
remember the time when it didn't work as expected, until (mid-?) october it
started to regress again. Is this on anyone's radar?
This bug is quirks-only, of course.  The problem is that in quirks sites expect
the font size and color of the text to be used for the underline, so we just get
the underline from the font.  And the bold font has a bold underline...
Summary: Text that's bold and underlined is handled wrong → [quirks]Text that's bold and underlined is handled wrong

Comment 9

15 years ago
*** Bug 250857 has been marked as a duplicate of this bug. ***

Comment 10

15 years ago
This appears to be fixed now, at least under Windows. Anybody still having a
problem with the test case?
Worksforme too, but it likely depends on the exact font used....
Assignee: clayton → nobody
QA Contact: chrispetersen → layout
Attachment 13548 [details] is WFM against Trunk (both GDI / D2D on Win7) and fails on 3.6.
This was fixed a few years ago by bug 403524, I believe.
Status: NEW → RESOLVED
Closed: 19 years ago4 years ago
Depends on: 403524
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.