dependparser.py uses deprecated sets module

VERIFIED DUPLICATE of bug 510038

Status

Tamarin
Build Config
VERIFIED DUPLICATE of bug 510038
9 years ago
9 years ago

People

(Reporter: Chris Dearman, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.11) Gecko/2009060309 Ubuntu/9.04 (jaunty) Firefox/3.0.11
Build Identifier: 

The sets module has been deprecated in python-2.6. Building Tamarin with a recent python installation generates deprecation warnings.

Reproducible: Always

Steps to Reproduce:
If python2.6 is installed by default then simply running make will generate the warnings, otherwise:
make PYTHON=/usr/bin/python2.6

Actual Results:  
Compiling core/AbcParser
/opt/tamarin/tamarin-redux/build/dependparser.py:45: DeprecationWarning: the sets module is deprecated
  from sets import Set
Compiling core/ActionBlockConstants
...


Expected Results:  
Compiling core/AbcParser
Compiling core/ActionBlockConstants
...


There's a simple backwards compatible patch that works with python2.5 and python2.6
(Reporter)

Comment 1

9 years ago
Created attachment 388505 [details] [diff] [review]
Avoid using deprecated sets module if possible
(Reporter)

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 510038

Updated

9 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.