Add Print preview command to context menu

VERIFIED DUPLICATE of bug 204519

Status

()

Firefox
Menus
--
enhancement
VERIFIED DUPLICATE of bug 204519
9 years ago
9 years ago

People

(Reporter: Markus Ernst, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11

Having Print preview in the context menu (as it is in Thunderbird) would be an enhancement anyway; but in some special cases the fact that it is missing there is really annoying, namely:
- in windows opened by a script, with missing menu bar
- in frame sets, where I would expect a "Print preview for this frame" in the "This frame" section

Reproducible: Always

Steps to Reproduce:
1. Open http://www.sbb.ch
2. Enter "Z├╝rich" in the "Von" field, "Bern" in the "Nach" field and click "Verbindung suchen" (or hit the Enter key)
3. Under the list of connections click "Druckansicht" (which is print version)
4. Cancel the printing dialog, as you might want to use print preview (in order to save paper, or because you remember having made your last print in landscape format with 200% scaling, or whatever)
Actual Results:  
There is no possibility to use print preview from this window.

Expected Results:  
Find "Print preview" in the context menu.

Of course the problem occurs due to bad authoring here. (I had some correspondence about this with SBB, the major swiss railway company; they refused to add menu and tool bars to the window as their web agency did not like them.) 

Anyway this kind of bad authoring is quite widespread in the real world. Also, you still find lots of framed pages. Having the "Print this frame" option in the context menu is good; but additionnally having a print preview would be better.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 204519
(Reporter)

Comment 2

9 years ago
I do not agree - bug 204519 is actually about a Print option, which is present in the recent versions of Firefox. My request is for a Print preview option!
Everything you need is in the file menu. There is no need for such a rarely used option inside the context menu. Bug 204519 also takes care about that.
Status: RESOLVED → VERIFIED

Comment 4

9 years ago
(In reply to comment #2)
> I do not agree - bug 204519 is actually about a Print option, which is present
> in the recent versions of Firefox. My request is for a Print preview option!

It's the same thing (or do you want to add a Print Preview *without* a Print
button ?)

The idea was to keep the context menu clean. As a result, the possibly to print
a single frame was lost, you can only print a single page. Similarly, you can't
print from the separate window. I do agree that this is a lose of
functionality, but it was decided to simplify the context menu : lots of people
got confused because they use the context menu, but could only print a frame,
not realizing that they had to use the menubar.

Also note that this is NOT the preview from the browser's point of view - this
is a regular page, which you can print. Or not (by pressing cancel). If you
change your mind, there'ss a "Drucken" link at the top left. This is also
useful for people who don't know how to use a context menu. But it's true that
you can't select a real preview (from the browser's point of view) form that
page, since there's no menubar. Unless you have a Mac, where you can choose
preview from inside the print dialog.
(Reporter)

Comment 5

9 years ago
(In reply to comment #3)
> Everything you need is in the file menu. 

Then we actually need an option in the advanced Javascript settings that disables removing the file menu from a window by authors. 

> There is no need for such a rarely used option inside the context menu. 

Do you have any statistical data about the use of print preview from the context menu in Thunderbird or in IE, that confirm this statement? I doubt that "View background image" is used more often.

> Bug 204519 also takes care about that.

In fact, there is a controversial discussion on the Print command in Bug 204519. And there is a Print command in the context menu in Firefox 3.0, so it must have been added since 2006, despite Bug 204519 is still WONTFIX.

However, I don't insist; I will just install the extension that does the job. Actually, IMO a print preview should be a standard option in any print dialog rather than a menu command anyway.
(Reporter)

Comment 6

9 years ago
(In reply to comment #5)
> And there is a Print command in the context menu in Firefox 3.0, so it
> must have been added since 2006, despite Bug 204519 is still WONTFIX.

Oops - that was "Print frame", not "Print". So I withdraw this point.
You need to log in before you can comment on or make changes to this bug.