closing last tab shows tab bar with "Always show the tab bar" off, and browser.tabs.closeWindowWithLastTab = false

RESOLVED FIXED in Firefox 3.7a1

Status

()

Firefox
Tabbed Browser
RESOLVED FIXED
9 years ago
7 years ago

People

(Reporter: Dan, Assigned: dao)

Tracking

3.5 Branch
Firefox 3.7a1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1) Gecko/20090715 Firefox/3.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1) Gecko/20090715 Firefox/3.5

Firefox 3.5 built on Linux

When I turn off "Always show the tab bar" the tab bar should only show when there is more than 1 tab. If there is only 1 tab there should be no tab bar.

With the preference "Always show the tab bar" OFF and about:config option browser.tabs.closeWindowWithLastTab = false, and there is only 1 tab(no tab bar showing) if you close the last tab it will bring up a blank page and show the tab bar with only 1 tab. The tab bar should not be showing.

Reproducible: Always

Steps to Reproduce:
1. Change about:config option browser.tabs.closeWindowWithLastTab = false
2. Uncheck "Always show the tab bar" in Preferences under Tabs
3. Close all tabs but the last one
4. Close the last tab with File>Close or CTRl+W
Actual Results:  
The tab is closed, a blank page shows, and the tab bar appears with just 1 tab.

Expected Results:  
The tab should close, show a blank page, and NO tab bar should be showing.
(Reporter)

Updated

9 years ago
Version: unspecified → 3.5 Branch
(Reporter)

Updated

9 years ago
Summary: with "Always show the tab bar" off, and browser.tabs.closeWindowWithLastTab = false, closing last tab shows tab bar → closing last tab shows tab bar with "Always show the tab bar" off, and browser.tabs.closeWindowWithLastTab = false
(Assignee)

Updated

9 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

9 years ago
OS: Linux → All
Hardware: x86 → All

Comment 1

9 years ago
The behavior previous to Ff 3.5 was correct, &, when attempting to close the last tab in the above circumstances, would flash creating a new tab followed by closing the current (previously last) tab.  Since Ff 3.5 beta(s), this behavior is exhibited.

Currently, I sidestep this by manually opening a new tab, & closing the previous one, which still works.

Any coders interested?

Updated

9 years ago
Flags: wanted1.8.1.x?
Flags: in-testsuite?
Flags: in-litmus?
Flags: blocking1.9.1.1?
Flags: blocking1.9.0.13?
Flags: blocking1.9.0.12?
Flags: blocking1.8.1.next?
Flags: blocking-firefox3.6?
@TPSamuel: this is not this bug, rather see Bug 456405. And please do note abuse flag usage.
Flags: wanted1.8.1.x?
Flags: in-testsuite?
Flags: in-litmus?
Flags: blocking1.9.1.1?
Flags: blocking1.9.0.13?
Flags: blocking1.9.0.12?
Flags: blocking1.8.1.next?
Flags: blocking-firefox3.6?

Comment 3

9 years ago
I think this bug is valid, as I've read the mentioned bug's comments, & it doesn't precisely address *this* issue.  As I understand it, *that* bug is regarding

browser.tabs.closeWindowWithLastTab = false

not being honored, which is *not* the problem I'm having. For me, the setting _is_ being honored, but the tab bar stays *stuck* visible with the last tab closed, although my config regarding "Always show tab bar" is false.

& I apologize very much for the abusive flag spam.
(Reporter)

Comment 4

9 years ago
This bug is not about the about:config option working or not. It DOES seem to work, since the last tab is "closed". The problem is that the tab bar is showing when it is not suppose to.

Comment 5

9 years ago
I forgot to mention that I'm experiencing this on 3.5* on Vista 32-bit
(Assignee)

Updated

9 years ago
Assignee: nobody → dao
(Assignee)

Comment 6

9 years ago
Created attachment 390646 [details] [diff] [review]
patch
Attachment #390646 - Flags: review?(gavin.sharp)
Attachment #390646 - Flags: review?(gavin.sharp) → review+
(Assignee)

Comment 7

8 years ago
http://hg.mozilla.org/mozilla-central/rev/f077fca0d235
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.7a1
(Assignee)

Updated

8 years ago
Attachment #390646 - Flags: approval1.9.2.1?
(Assignee)

Updated

8 years ago
Duplicate of this bug: 546699
Comment on attachment 390646 [details] [diff] [review]
patch

We missed 1.9.2.2.  Moving approval request forward.
Attachment #390646 - Flags: approval1.9.2.2? → approval1.9.2.3?
(Assignee)

Updated

8 years ago
Attachment #390646 - Flags: approval1.9.2.5?

Updated

8 years ago
Attachment #390646 - Flags: approval1.9.2.7?
Attachment #390646 - Flags: approval1.9.2.6-
Attachment #390646 - Flags: approval1.9.2.5?
Attachment #390646 - Flags: approval1.9.2.4?

Comment 10

8 years ago
Comment on attachment 390646 [details] [diff] [review]
patch

We will not be taking this for 3.6.6. Moving approval request forward.

If you disagree, send me an email.
Attachment #390646 - Flags: approval1.9.2.9?
You need to log in before you can comment on or make changes to this bug.