Can't add comment when declining a meeting invitation

RESOLVED DUPLICATE of bug 433848

Status

Calendar
E-mail based Scheduling (iTIP/iMIP)
--
enhancement
RESOLVED DUPLICATE of bug 433848
9 years ago
8 years ago

People

(Reporter: Calvin Webster, Unassigned)

Tracking

Lightning 0.9
x86_64
Linux

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.11) Gecko/2009061118 Fedora/3.0.11-1.fc9 Firefox/3.0.11
Build Identifier: version 0.9 build 2008092321

When declining a meeting invitation there is no provision for sending a short comment. It's often customary to offer a reason/excuse for not attending an event. One must reply to the original message to explain, resulting in multiple responses from each non-attendee. Evolution provides this feature and I believe Outlook does too.

Reproducible: Always

Steps to Reproduce:
1. Receive a meeting invitation
2. Click [Decline] button

Actual Results:  
Meeting request response options are comprised of 3 buttons in a bar across the top of the message. Only options are [Accept], [Decline], [Tentative].
After clicking [Decline] button the confirmation dialog appears with a checkbox to support Outlook 2000/2002/XP.
After clicking [OK] to confirm, notification emails are sent.

Expected Results:  
Many users would like the option to offer a short explanation why they cannot attend an event.Those who are switching from Outlook or Evolution will expect this behavior.
(Reporter)

Updated

9 years ago
Version: unspecified → Lightning 0.9

Comment 1

9 years ago
See related Bug 433848.
Component: Lightning Only → E-mail based Scheduling (iTIP/iMIP)
QA Contact: lightning → email-scheduling
(Reporter)

Comment 2

9 years ago
Sorry, my search didn't turn up that one. Fixing Bug 433848 should satisfy this one. It doesn't look like there has been any real activity on it for almost a year, though. Other related bugs referenced seem to center around a discussion of attachments. Why not return the previous behavior, offering a compose window, then decide about attachments? Bug 404050 even has a patch but but it has been deferred until related Bug 463402 is resolved. These should not block this bug IMO. While it may be inconvenient to have to click the Send button, it is even more inconvenient to have no options. Thanks for the great plug-in, though. :-)
bug 433848 needs some Thunderbird API fixes, but given all the other bugs that need fixing, I think thats the best we can do at the moment. I'd like to see bug 433848 fixed too though.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 433848
You need to log in before you can comment on or make changes to this bug.