Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 504714 - about:sessionrestore should suppress middlemouse.contentLoadURL
: about:sessionrestore should suppress middlemouse.contentLoadURL
Product: Firefox
Classification: Client Software
Component: Session Restore (show other bugs)
: 3.5 Branch
: All Linux
: -- normal (vote)
: Firefox 6
Assigned To: Paul O'Shannessy [:zpao] (not reading much bugmail, email directly)
: Mike de Boer [:mikedeboer]
: 605939 (view as bug list)
Depends on:
  Show dependency treegraph
Reported: 2009-07-16 18:44 PDT by scientus
Modified: 2011-08-24 08:23 PDT (History)
6 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---

Patch v0.1 (922 bytes, patch)
2010-12-08 16:16 PST, Paul O'Shannessy [:zpao] (not reading much bugmail, email directly)
dietrich: review+
Details | Diff | Splinter Review

Description scientus 2009-07-16 18:44:04 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/2009032712 Firefox/3.0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20090714 Shiretoko/3.5.1pre

If you middle click on a tab from session restore with middlemouse.contentLoadURL;true and a url in you clipboard the sessionrestore changes to that url and the tab you clicked on restores in a new tab

Reproducible: Always

Steps to Reproduce:
1.get to session restore
2.have middlemouse.contentLoadURL;true (default linux)
3.copy into clipboard a url
4.middle click to restore a tab
Actual Results: restores switches to pasted url

Expected Results: restores

related to bug 414345
Comment 1 Simon Bünzli 2009-07-31 04:59:45 PDT
What happens when you middle-click a hyperlink in a regular web page? If instead of opening a new tab, the URL from the clipboard is loaded, this bug is likely WONTFIX.
Comment 2 scientus 2009-07-31 05:03:26 PDT
This works exactly as expected on hyperlinks in a regular web page, (same as other platforms/middlemouse.contentLoadURL=false i.e. open in a new tab, no clipboard action) otherwise you would have every Linux user yelling at you.

This bug is specific to the session restore XUL page.
Comment 3 Simon Bünzli 2009-07-31 05:14:27 PDT
Right, browser.js's contentAreaClick will have to be taught about either XUL (trees) in general or about:sessionrestore's <xul:tree id="tabList"> in particular.
Comment 4 [:Aleksej] 2010-02-02 10:23:00 PST
Confirmed with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a1pre) Gecko/20100202 Minefield/3.7a1pre
Comment 5 [:Aleksej] 2010-12-08 13:20:26 PST
This still happens with Mozilla/5.0 (X11; Linux i686; rv:2.0b8pre) Gecko/20101208 Firefox/4.0b8pre
Comment 6 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2010-12-08 13:23:32 PST
We should probably get this fixed for Firefox 4.0.  Adding a blocking? nomination.
Comment 7 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2010-12-08 14:00:27 PST
Not a dupe, but probably related:
bug 605939
Comment 8 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2010-12-08 16:12:28 PST
I would blocking- this if I could. Not something I would hold shipping for. That said it might be easy to fix.

Simon: Not sure how closely you're reading bugmail, but couldn't we just stop propagation if we process the middle click? A quick test seems like it's doing the right thing
Comment 9 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2010-12-08 16:16:47 PST
Created attachment 496343 [details] [diff] [review]
Patch v0.1

Seems to work without having to special case this particular tree
Comment 10 Dietrich Ayala (:dietrich) 2010-12-13 16:56:40 PST
Narrow, not holding the release for this.
Comment 11 Dietrich Ayala (:dietrich) 2011-04-25 11:06:53 PDT
Comment on attachment 496343 [details] [diff] [review]
Patch v0.1

sounds like the simpler solution. looks fine, r=me.
Comment 12 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2011-05-13 14:16:16 PDT
Comment 13 George Carstoiu 2011-06-29 05:27:43 PDT
Mozilla/5.0 (X11; Linux i686; rv:7.0a1) Gecko/20110629 Firefox/7.0a1

Verified using the steps to reproduce from Comment 1 on Ubuntu 11.04, Mac OS X 10.6, Win7, WinXP.

Issue no longer reproducible -> Setting status to Verified Fixed.
Comment 14 v387 2011-08-24 08:23:44 PDT
*** Bug 605939 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.