Couldn't respond to error message; mozilla effectively locked

VERIFIED DUPLICATE of bug 28467

Status

()

Core
Event Handling
P3
critical
VERIFIED DUPLICATE of bug 28467
18 years ago
16 years ago

People

(Reporter: jesup, Assigned: joki (gone))

Tracking

({hang})

Trunk
mozilla0.9
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Win95 2000082508
I was trying to access a bug in bugzilla, which wasn't responding fully (hung at
50% repeatably).  I was doing something in another window (updating RealPlayer),
and click on Mozilla in the task bar.  Mozilla had finally timed out after 140
seconds trying to access bugzilla, and had put up an error requester.  The
problem was that the requester didn't have focus (though the Mozilla window
did), and I couldn't select the Ok button or give it focus.  When I tried to
click on entries in the Mozilla window, I got beeps (probably due to a modal
requester being up).  I had to kill the mozilla process to get out of the
situation.  Effectively as bad as a crash.
I have seen this too on NT. I am adding the crash keyword because even though 
Mozilla itself hasn't crashed you cannot do anything with it except kill it from 
the process list.

I think this is quite rare situation (I have seen it only once or twice) so I 
don't think this needs to be on nsbeta3 list.
Keywords: crash
This bug has been marked "future" because the original netscape engineer working 
on this is over-burdened. If you feel this is an error, that you or another
known resource will be working on this bug,or if it blocks your work in some way 
-- please attach your concern to the bug for reconsideration.
Severity: major → critical
Target Milestone: --- → Future

Comment 3

18 years ago
Updating QA Contact.
QA Contact: janc → lorca
Changing crasher bug milestone to mozilla0.9.
Target Milestone: Future → mozilla0.9
Changing crash keyword to hang.
Keywords: crash → hang
Reassigning QA Contact for all open and unverified bugs previously under Lorca's
care to Gerardo as per phone conversation this morning.
QA Contact: lorca → gerardok
(Assignee)

Comment 7

18 years ago
I have not been able to recreate the bug in exactly the manner described below 
(every time I've forced an error message in another window it comes forward with 
the dialog focused) but the state described is clearly the same as bug 28467, a 
modal alert/dialog loses focus to the page behind it creating a state where the 
dialog cannot be clicked on and the modality prevents accessing the page.  I'm 
going to mark it as a dupe.  

*** This bug has been marked as a duplicate of 28467 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 8

17 years ago
QA contact updated
QA Contact: gerardok → madhur

Updated

16 years ago
QA Contact: madhur → rakeshmishra

Updated

16 years ago
QA Contact: rakeshmishra → trix

Comment 9

16 years ago
verified dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.