Keyboard Shortcut Issue (Ctrl+Home / Ctrl+End not working...most likely because tab "focus" feature broken)

VERIFIED DUPLICATE of bug 491178

Status

()

Firefox
Keyboard Navigation
--
major
VERIFIED DUPLICATE of bug 491178
9 years ago
9 years ago

People

(Reporter: Evan, Unassigned)

Tracking

3.5 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)

You are now chatting with Firefox community member hwillauer
hwillauer: Hello, how can i help you today
Evan: hi
Evan: Since upgrading to Firefox 3.5, the keyboard shortcuts to move tabs
along the tab bar don't work. Your knowledge base still says that
Ctrl+Home (or Ctrl+End), while the tab is selected, will move the
tabs. This is how it always used to work in older versions...the user
clicks a tab to activate it in the browser window, clicks the tab
again to select the tab itself (so that the tab name has a little
selection box around it), then hits Ctrl+Home to move the tab. It
used to work great.

Now, there is no way to select the tab...we can make it active in the
browser window, but can't select or highlight the tab itself...and
because of that, it's also impossible to use the keyboard shortcuts to
move tabs as we could before. Please correct this bug, or update your
Keyboard Shortcuts knowledge base with the correct command. This
shortcut was a huge timesaver, allowing the user to move a tab at the
end of the tab bar to the very front without clicking, dragging, and
waiting for the entire bar to scroll.
Evan: i'm not sure why the old shortcuts stopped working...would love more information, a fix, or something
hwillauer: you may want to look at http://support.mozilla.com/en-US/kb/Keyboard+shortcuts
Evan: i had.
Evan: from that page: Move Tab to Beginning
(when tab is focused) Ctrl Cmd+Home
Move Tab to End
(when tab is focused) CtrlCmd+End
Evan: er, it actually says Ctrl+Home on the page
Evan: the issue seems to center on being able to "focus" the tab
hwillauer: i just tried it for my self and i got the same issue
Evan: in previous versions, the first click on a tab would select it to view the page contents, and clicking again would focus the tab itself and make the tab title highlit with a little box to signify that it was selected/focused
Evan: yeah, I don't think it's user error
hwillauer: open a bug report
Evan: I tried different ways to click on the tab...left click (select), right click (context menu), center click (closes the tab), double click, etc.
Evan: unless you know a keyboard shortcut or other command to focus the tab after selecting it, i'll do a bug report
hwillauer: all of the keyboard shortcuts for focus tab are not working for me 

Reproducible: Always

Steps to Reproduce:
1.click a tab
2.click a tab again
3.tab name should be highlit with a little selection box...and Ctrl+Home or Ctrl+End should move tab to beginning/end of list...neither part of step 3 works in Firefox 3.5
Actual Results:  
tab can be selected to show page contents, but tab title itself can not be focused in firefox 3.5.  Ctrl+Home and Ctrl+End keyboard shortcuts do not work.

Expected Results:  
tab name should be highlit with a little selection box...and Ctrl+Home or Ctrl+End should move tab to beginning/end of list
(Reporter)

Updated

9 years ago

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Version: unspecified → 3.5 Branch
Duplicate of bug: 491178
(Reporter)

Updated

9 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 2

9 years ago
This is not a duplicate of bug 491178...that one is about being about to change the selected tab that shows in the page view window.

this issue, 504854, relates to being able to MOVE and FOCUS tabs (select their titles the way you used to be able to by clicking a tab twice in firefox versions prior to 3.5)

Comment 3

9 years ago
This is a dupe, see any of the half dozen other bugs duped. The issue is that the the tab is not focusable. If the bug gets fixed and this issue is not resolved then feel free to reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 491178
(Reporter)

Comment 4

9 years ago
ok, they're related issues, but not resolved.  I live chatted with a Firefox person today, and they wanted a new bug report.  please don't mark this one resolved until it is actually fixed (the change was not intended as part of 3.5, and the keyboard shortcuts knowledge base item still reflects the tab focus and move functionality for 3.5).  I will keep the duplicate link noted.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 5

9 years ago
What's funny, while devs decided to get rid of tab focusing (I vaguely remember such discussion few months ago) they didn't change underlying mechanisms - it's still possible to focus a tab: go to search bar, then hit 'Tab'.
And moving pages around - all like you used to.
So, I take it you and me are 'minorities' now, as devs favors less geeky types, and strip anything which stands in a way of "streamlining" both: feature set & code. And I fear they'll take it away completely, not only interface, but strip away now "redundant" code.

Comment 6

9 years ago
I have renamed Bug 491178 to also cover this bug, as both arise from the same issue, and am marking this as a duplicate of it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 491178

Updated

9 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.