Large Table Rendering Hangs Firefox 3.5/3.5.1

RESOLVED DUPLICATE of bug 477564

Status

()

--
critical
RESOLVED DUPLICATE of bug 477564
9 years ago
9 years ago

People

(Reporter: alexnchavez_2006, Unassigned)

Tracking

3.5 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)

The problem says solved, but when I try the sample page located @ http://www.occultations.org/TestFF35.html and in my own application(sorry cannot give link, internal site) where I am using a large table the problem still occurs. The larger the table the longer the hang and cpu/memory usage spikes. 

Additionally once the large table is loaded, if any change is made to the page in the DOM where the page object are replaced/reorganized the hang reoccurs because the large table is being rendered again. 

There are no error messages that occur in the Error Console, but CPU usage spikes to above 50% and memory spikes as well and high I/O to the disk. Clicking the Firefox window or letting it hang for enough time and the window will say "Firefox (Not Responding)" in which if the table is too large I have to end the firefox process from task manager and restart firefox and hope that the window comes up to allow me to not reopen the page, which when this problem occurs doesnt always happen correctly. 

Side note, loading these pages in Firefox 3.0.xx the problem does not occur at all, runs perfect.


Also See: 

https://support.mozilla.com/tiki-view_forum_thread.php?comments_parentId=394490&forumId=1

and

https://support.mozilla.com/tiki-view_forum_thread.php?comments_parentId=383246&forumId=1

Reproducible: Always

Steps to Reproduce:
A:
1. Load this page http://www.occultations.org/TestFF35.html
2. Begin scrolling the page.

B:
1. Create an HTML page with a large table of 500+ rows with drop down that has an onchange event which will modify the page content innerHTML in a div
2. Select an item from the drop down so the function to replace the div innerHTML is called
3. The DOM is updated to reflect these changes, the large table is rendered or updated in the background causing firefox to hang again even after the table has been rendered the first time.
Actual Results:  
Firefox 3.5 and 3.5.1 hangs and cannot be closed unless closed through the task manager, the larger the table the longer the hang, potentially indefinitely if your system runs out of system resources for CPU/Memory

Expected Results:  
Page should render fine and not hang the browser or use extensive system resources to render a larger html table. Previous versions of Firefox dont have this problem.

System Specs: 

Windows 7 RC1 Ultimate 64-bit/Windows Vista Ultimate 64-bit SP2: 
Intel Core 2 Duo 2.4GHz, 4GB 667MHz DDR2, NVidia GeForce 8600 GS, Resolution 1680x1050 

Windows XP SP3: 
Intel Quad Core 3.0GHz, 4GB 866MHz DDR2, NVidia Quadro, Resolution 1680x1050 

My systems are quite capable of rendering the page, especially in IE6/7, Firefox 2,3.0.xx
(Reporter)

Updated

9 years ago
Version: unspecified → 3.5 Branch
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 477564
You need to log in before you can comment on or make changes to this bug.