Closed Bug 505012 Opened 11 years ago Closed 11 years ago

Drag'n'drop doesn't work on <input type="file"> tag

Categories

(Core :: DOM: Drag & Drop, enhancement)

x86
macOS
enhancement
Not set

Tracking

()

VERIFIED DUPLICATE of bug 50660

People

(Reporter: folletto.id, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1

Drag'n'dropping inside the Firefox window opens the dropped file correctly.

On the <input type="file"> instead it should allow attaching that file, with the same exact result of clicking on "Browse" and choosing from the popup file locator window.

From the specs (http://www.w3.org/TR/html401/interact/forms.html#file-select):
"This control type allows the user to select files so that their contents may be submitted with a form. The INPUT element is used to create a file select control."

Drag'n'drop isn't excluded as a way to manage "allows the user to select files". It doesn't explicitly state how it should be designed that part, and drag'n'drop doesn't broke anything, since until now drag'n'drop isn't allowed in any way.

It should be checked out more deeply, but it should not break anything also in regard to the current HTML 5 draft (4.10.4.1.18 File Upload state and 7.10 Drag and drop).

Reproducible: Always

Steps to Reproduce:
1. Open any page with a <input type="file"> control.
2. Drag'n'drop a file from the desktop to the control itself on the current page.
Actual Results:  
The file dropped is opened inside the Firefox window.

Expected Results:  
The file should have been attached inside the <input type="file">
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 50660
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.