Resizing Samoa Wikipedia page will hang FF (speculate, floating items width calculation)

RESOLVED WORKSFORME

Status

()

Core
Layout
--
critical
RESOLVED WORKSFORME
9 years ago
3 years ago

People

(Reporter: u348128, Unassigned)

Tracking

1.9.1 Branch
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME, URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)

This is a split of bug 500103. That bug is about a crash, but somehow the Samoa page was mentioned.

If you go to the Samoa site and you resize as shown in the attachment (which I will add in next comment), then Firefox hangs. You need right size of font, maybe slightly different fonts on Mac/Linux prevent reproduction.

In general this is also a poor performance bug. Resizing close to the hang situation is sluggish.

Reproducible: Always

Steps to Reproduce:
1. Go to Samoa page on English Wikipedia.
2. Resize as shown in attachment.
3.
Actual Results:  
Hang

Expected Results:  
No hang.

Speculation:

The FF algorithm to calculate width gets into a infinite loop. Close to the hang situation the horizontal scroll bar suddenly gets shorter (meaning the width larger). This may be the result of the floating items on left and right. If the new width leads to other sizing problems on another part of the page, this may lead to again a new width calculation.

As said, this is speculation purely based on the visible behavior.

The test case is VERY hard to reduce. Removing parts often makes the case not reproducible anymore.

I have seen some bug in bugzilla, that might be a dupe of this bug.
(Reporter)

Comment 1

9 years ago
Created attachment 389559 [details]
Resize the Samoa page exactly as in the picture. It must be pixel accurate.

Be sure you have the same sized fonts.

Resizing is very slow close to the hang situation.
(Reporter)

Comment 2

9 years ago
It might be related to bug 505074. Little bit same behavior, also a website with difficult width calculation.
Confirmed hang on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

9 years ago
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Version: unspecified → 1.9.1 Branch

Updated

9 years ago
OS: Windows XP → All

Updated

9 years ago
Whiteboard: DUPEME
Is this a regression from 3.0?  If so, do we know when (on mozilla-central) it regressed?
After considerable resizing both on *nix and windows I say WFM
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.