Cursor image does not change when dragging tab

RESOLVED DUPLICATE of bug 483776

Status

()

RESOLVED DUPLICATE of bug 483776
9 years ago
9 years ago

People

(Reporter: ArtKns, Unassigned)

Tracking

({regression})

3.5 Branch
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5

Cursor image should append little box when dragging tab icon to anyplace other than the tab bar - such as the bookmarks toolbar, bookmarks menu, etc. This worked OK in v3.0. The URL is captured and dropped OK it is just the indication of the content. This is probably similar to bug #461696

Reproducible: Always

Steps to Reproduce:
1.Click & hold on a tab icon
2.drag to bookmarks toolbar
3.
Actual Results:  
cursor does not change 

Expected Results:  
little box should be appended to bottom of cursor
I see a miniature website picture but no cursor change indeed.
This was changed per Bug 463088. It seems an intentional change.
Keywords: regression
Version: unspecified → 3.5 Branch
(Reporter)

Comment 2

9 years ago
It doesn't make sense for it to be intentional. It is a necessary feedback to differentiate between actually dragging an object (the tab) vs a simple cursor movement. Just because a mouse key is depressed does NOT ensure that anything is being dragged. The behavior of dragging an icon from the navigation window still works as it should including the cursor change to the slashed "O" over areas where the object cannot be dropped. Both of these cursor feedback behaviors are required. Very frequently I have to repeat a drag and drop operation because the initial click did not "pick-up" the object. The cursor change is the only indication of "pick-up" success.

Looking at 463088 it does appear to be a deliberate but not very well thought out change. "Tear off" only applies after the cursor has moved outside of the FF window. It has no "tear off" meaning inside the parent window. Inside the parent window a tab drag and drop could be a tab reorder (within the tab bar) or an operation to place the tab URL onto a toolbar or bookmark. Being limited to the navigation window icon for proper behavior is not sufficient as that operation has the annoying action of showing a tooltip for 10 - 20 seconds that covers up the target toolbar icons.

So what do I do now? Create another bug? Add this to 463088?

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 483776
You need to log in before you can comment on or make changes to this bug.