JS error on Google Docs (spreadsheets) with jit enabled

RESOLVED DUPLICATE of bug 511050

Status

()

defect
P2
normal
RESOLVED DUPLICATE of bug 511050
10 years ago
4 years ago

People

(Reporter: marcia, Unassigned)

Tracking

({regression})

Trunk
Points:
---
Bug Flags:
blocking1.9.2 +

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(1 attachment)

Seen using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090721 Minefield/3.6a1pre.

STR:
1. Go to Google docs.
2. Observe the navigation bar is completely greyed out.

Checked Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 and it works fine there.
Whiteboard: DUPEME
Error: this[Jf][b] is null
Source File: http://spreadsheets.google.com/client/js/3823401514-trix_core.js
Line: 479 is the only error that appears in the console.
Bug 505543 seems to have a similar script error.
Do you mean the nav bar for a spreadsheet?

For a document the nav bar works fine for me, but I'm getting the slow script warning. I filed bug 504797 about that some times ago.
This has the same regression range as bug 504797 and only fails with jit enabled. Maybe it could be a duplicate, but let's make this one the spreadsheet error and the other one the unresponsive script warning for now.
Assignee: nobody → general
Component: General → JavaScript Engine
Keywords: testcase-wanted
OS: Mac OS X → All
Product: Firefox → Core
QA Contact: general → general
Hardware: x86 → All
Summary: Google Docs nav bar not functional in latest trunk nightly, works using 3.5.1 → JS error on Google Docs (spreadsheets) with jit enabled
Whiteboard: DUPEME
Flags: blocking1.9.2+
Priority: -- → P2
This is related to settings in the used profile. Marcia, do you also see it in a fresh profile?
Mmh, shall we dupe to bug 511050? Looks like the same issue.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 511050
You need to log in before you can comment on or make changes to this bug.