Closed Bug 505525 Opened 11 years ago Closed 8 years ago

nsWindowsShellService.cpp build failure due to gfxIImageFrame removal

Categories

(SeaMonkey :: OS Integration, defect, blocker)

x86
Windows Server 2003
defect
Not set
blocker

Tracking

(Not tracked)

VERIFIED FIXED
seamonkey2.0b2

People

(Reporter: kairo, Assigned: neil)

References

Details

Attachments

(4 files, 4 obsolete files)

cl -FonsWindowsShellService.obj -c  -DMOZ_MAIL_NEWS -DMOZ_SUITE=1 -DOSTYPE=\"WINNT5.2\" -DOSARCH=WINNT  -I/e/builds/slave/comm-central-trunk-win32/build/suite/shell/src -I. -I../../../mozilla/dist/include/xpcom -I../../../mozilla/dist/include/string -I../../../mozilla/dist/include/uriloader -I../../../mozilla/dist/include/dom -I../../../mozilla/dist/include/intl -I../../../mozilla/dist/include/necko -I../../../mozilla/dist/include/content -I../../../mozilla/dist/include/imglib2 -I../../../mozilla/dist/include/gfx -I../../../mozilla/dist/include/widget -I../../../mozilla/dist/include/pref -I../../../mozilla/dist/include/msgMapi -I../../../mozilla/dist/include/layout -I../../../mozilla/dist/include   -I../../../mozilla/dist/include/shellservice -I../../../mozilla/dist/include/nspr    -I../../../mozilla/dist/sdk/include       -GR- -TP -nologo -Zc:wchar_t- -W3 -Gy -Fdgenerated.pdb  -DNDEBUG -DTRIMMED -Zi -UDEBUG -DNDEBUG -O1 -MD            -D_CRT_SECURE_NO_DEPRECATE=1 -D_CRT_NONSTDC_NO_DEPRECATE=1 -DHAVE_SDKDDKVER_H=1 -DWINVER=0x500 -D_WIN32_WINNT=0x500 -D_WIN32_IE=0x0500 -DMOZ_WINSDK_TARGETVER=0x06000000 -DMOZ_NTDDI_WS03=0x05020000 -DMOZ_NTDDI_LONGHORN=0x06000000 -DMOZ_NTDDI_WIN7=0x06010000 -DX_DISPLAY_MISSING=1 -DMOZILLA_VERSION=\"1.9.2a1pre\" -DMOZILLA_VERSION_U=1.9.2a1pre -DHAVE_SNPRINTF=1 -D_WINDOWS=1 -D_WIN32=1 -DWIN32=1 -DXP_WIN=1 -DXP_WIN32=1 -DHW_THREADS=1 -DSTDC_HEADERS=1 -DWIN32_LEAN_AND_MEAN=1 -DNO_X11=1 -DHAVE_MMINTRIN_H=1 -DHAVE_OLEACC_IDL=1 -DHAVE_ATLBASE_H=1 -DHAVE_WPCAPI_H=1 -D_X86_=1 -DD_INO=d_ino -DMOZ_EMBEDDING_LEVEL_DEFAULT=1 -DMOZ_EMBEDDING_LEVEL_BASIC=1 -DMOZ_EMBEDDING_LEVEL_MINIMAL=1 -DMOZ_SUITE=1 -DMOZ_BUILD_APP=suite -DMOZ_DEFAULT_TOOLKIT=\"cairo-windows\" -DMOZ_DISTRIBUTION_ID=\"org.mozilla\" -DIBMBIDI=1 -DMOZ_VIEW_SOURCE=1 -DACCESSIBILITY=1 -DMOZ_XPINSTALL=1 -DMOZ_JSLOADER=1 -DNS_PRINTING=1 -DNS_PRINT_PREVIEW=1 -DMOZ_NO_XPCOM_OBSOLETE=1 -DMOZ_XTF=1 -DMOZ_UPDATE_CHANNEL=nightly -DMOZ_PLACES=1 -DMOZ_FEEDS=1 -DMOZ_STORAGE=1 -DMOZ_HELP_VIEWER=1 -DMOZ_LOGGING=1 -DMOZ_MEMORY_SIZEOF_PTR_2POW=2 -DMOZ_MEMORY=1 -DMOZ_MEMORY_WINDOWS=1 -D_STATIC_CPPLIB=1 -DMOZ_USER_DIR=\"Mozilla\" -DMOZ_STATIC_MAIL_BUILD=1 -DMOZ_TREE_CAIRO=1 -DHAVE_UINT64_T=1 -DMOZ_XUL=1 -DMOZ_PROFILELOCKING=1 -DMOZ_RDF=1 -DMOZ_MORK=1 -DMOZ_MORKREADER=1 -DMOZ_DLL_SUFFIX=\".dll\"  -D_MOZILLA_CONFIG_H_ -DMOZILLA_CLIENT /e/builds/slave/comm-central-trunk-win32/build/suite/shell/src/nsWindowsShellService.cpp
nsWindowsShellService.cpp
e:/builds/slave/comm-central-trunk-win32/build/suite/shell/src/nsWindowsShellService.cpp(45) : fatal error C1083: Cannot open include file: 'gfxIImageFrame.h': No such file or directory
make[5]: Leaving directory `/e/builds/slave/comm-central-trunk-win32/build/objdir/suite/shell/src'
make[4]: Leaving directory `/e/builds/slave/comm-central-trunk-win32/build/objdir/suite'
make[3]: Leaving directory `/e/builds/slave/comm-central-trunk-win32/build/objdir'
make[2]: Leaving directory `/e/builds/slave/comm-central-trunk-win32/build/objdir'
make[5]: *** [nsWindowsShellService.obj] Error 2


Seen on comm-central-trunk Windows builds, caused by bug 753 checkin on mozilla-central
Blocks: 753
No longer depends on: 753
Attached patch Patch (obsolete) — Splinter Review
Copied necessary changes from http://hg.mozilla.org/mozilla-central/rev/b94bc4be53ca, included some ifdefs, Makefile change was not necessary, maybe we should copy the change anyway if we enable libxul one day?
Assignee: nobody → bugzilla
Attachment #389745 - Flags: review?(neil)
Comment on attachment 389745 [details] [diff] [review]
Patch


>+#else
>+  rv = WriteBitmap(file, container);
>+#endif
>+  

Ignore the whitespace change, fixed this already locally.
Attached patch Better patch (obsolete) — Splinter Review
Attachment #389745 - Attachment is obsolete: true
Attachment #389781 - Flags: review?(neil)
Attachment #389745 - Flags: review?(neil)
Attached patch Better patch (obsolete) — Splinter Review
Attachment #389781 - Attachment is obsolete: true
Attachment #389782 - Flags: review?(neil)
Attachment #389781 - Flags: review?(neil)
The Makefile changes are necessary on trunk, so asking KaiRo for build review.

r=me on mcsmurf's C++ except for some nits which this patch includes.
Attachment #389782 - Attachment is obsolete: true
Attachment #389799 - Flags: review?(kairo)
Attachment #389782 - Flags: review?(neil)
Comment on attachment 389799 [details] [diff] [review]
Include necessary Makefile changes
[Checkin: Comment 7]

r=me on the build changes.
Attachment #389799 - Flags: review?(kairo) → review+
Pushed changeset 860fb123cbac to comm-central.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Windows nightly (static build, while normal build cycles are shared) on comm-central-trunk fails with this message:

NEXT ERROR make[5]: *** No rule to make target `../../mozilla/dist/lib/thebes.lib', needed by `suite.dll'.  Stop.
make[5]: Leaving directory `/e/builds/slave/comm-central-trunk-win32-nightly/build/objdir/suite/build'


Reopening bug as the patch apparently doesn't work correctly in all cases.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
The problem is that there is no thebes.lib in mozilla/dist/lib. Guess we have to directly reference the thebes.lib in gfx/thebes/src ?
(In reply to comment #8)
> Windows nightly (static build, while normal build cycles are shared)
How static? thebes is linked into xul.dll; if it's therefore linked into seamonkey.exe then we'll need to link suite.lib into seamonkey.exe too.
OK, so hopefully what this should do is to link shellservice_s.lib into seamonkey.exe for static builds and suite.dll for nonstatic and libxul builds.
Attachment #390882 - Flags: review?(kairo)
Comment on attachment 390882 [details] [diff] [review]
More Makefile changes
[Checkin: Comment 23]

>diff -r 413ab70abcfb suite/app/Makefile.in
>--- a/suite/app/Makefile.in	Fri Jul 24 12:13:22 2009 -0700
>+++ b/suite/app/Makefile.in	Mon Jul 27 21:12:08 2009 +0100
>@@ -152,6 +152,12 @@
> 
> ifdef BUILD_STATIC_LIBS
> 
>+ifeq ($(OS_ARCH),WINNT)
>+ifeq (,$(MOZ_ENABLE_LIBXUL)$(MOZILLA_1_9_1_BRANCH))
>+LIBS += ../shell/src/$(LIB_PREFIX)shellservice_s.$(LIB_SUFFIX)
>+endif
>+endif
>+

Nit: MOZ_ENABLE_LIBXUL is always unset when BUILD_STATIC_LIBS is set.

Other than that, this looks good (I hope you have tested it with shared and static compiling under Windows as I can't, I don't have a build env available on that OS).
Attachment #390882 - Flags: review?(kairo) → review+
Attached patch More C++ changes (obsolete) — Splinter Review
To register the shell module in seamonkey.exe rather than shell.dll
Attachment #391149 - Flags: review?(kairo)
Comment on attachment 391149 [details] [diff] [review]
More C++ changes

All I can tell looks good, given you made sure it does the right thing actually, and also work for still doing things right on 1.9.1.
I'd like Frank to do an additional look on this, though.
Attachment #391149 - Flags: review?(kairo)
Attachment #391149 - Flags: review?(bugzilla)
Attachment #391149 - Flags: review+
Comment on attachment 391149 [details] [diff] [review]
More C++ changes

This doesn't work. Back to the drawing board.
Attachment #391149 - Flags: review?(bugzilla) → review-
OK, so this defines a new variable and links shell into seamonkey.exe - phew!
Attachment #391149 - Attachment is obsolete: true
Attachment #391420 - Flags: review?(kairo)
Attachment #391420 - Flags: review?(bugzilla)
Comment on attachment 391420 [details] [diff] [review]
Tested patch
[Checkin: Comment 21]

The build part looks good to me, if the patch as such works in all configurations we need (branch/trunk and shared/static).
Attachment #391420 - Flags: review?(kairo) → review+
As a note, it looks like at this moment, both branch and trunk static nightlies are broken with shellservice linking issues.
Attachment #391420 - Flags: review?(bugzilla) → review+
branch seems to work again, but the bustage fix broke trunk, apparently :(
(In reply to comment #19)
> branch seems to work again, but the bustage fix broke trunk, apparently :(

Which trunk build was that?
Fixed since then!?
http://hg.mozilla.org/comm-central/rev/638656f3d7e1 fixed building trunk but broke branch, we got one green trunk build out of that. http://hg.mozilla.org/comm-central/rev/8ea1a4f7177f fixed the branch bustage, but broke trunk again.
OK, so I need to set IS_COMPONENT et. al. before we include config.mk (and thus app-config.mk) so I had to duplicate the logic in each Makefile instead.
Attachment #392160 - Flags: review?(bugzilla)
Attachment #392160 - Flags: review?(bugzilla) → review+
Attachment #389799 - Attachment description: Include necessary Makefile changes → Include necessary Makefile changes [Checkin: Comment 7]
Attachment #390882 - Attachment is obsolete: true
Comment on attachment 390882 [details] [diff] [review]
More Makefile changes
[Checkin: Comment 23]


http://hg.mozilla.org/comm-central/rev/42cbb85c46ae
Attachment #390882 - Attachment description: More Makefile changes → More Makefile changes [Checkin: Comment 23]
Attachment #390882 - Attachment is obsolete: false
Comment on attachment 391420 [details] [diff] [review]
Tested patch
[Checkin: Comment 21]


http://hg.mozilla.org/comm-central/rev/638656f3d7e1
Attachment #391420 - Attachment description: Tested patch → Tested patch [Checkin: Comment 24]
Attachment #391420 - Attachment description: Tested patch [Checkin: Comment 24] → Tested patch [Checkin: Comment 21]
Attachment #392160 - Attachment description: I hate thebes → I hate thebes [Checkin: Comment 25]
Is there anything else to do in this bug?
Assignee: bugzilla → neil
I believe there has been a few green builds in the last two years on trunk so this could be considered fixed at least for the normal builds.
Status: REOPENED → RESOLVED
Closed: 11 years ago8 years ago
Resolution: --- → FIXED
V.Fixed, (assuming answer to comment 26 is implicitly "no").
Severity: normal → blocker
Status: RESOLVED → VERIFIED
Ftr, this bug was fixed in
"at Thu Sep 03 09:13:00 2009 -0700	SEAMONKEY_2_0b2_RELEASE"
Target Milestone: --- → seamonkey2.0b2
You need to log in before you can comment on or make changes to this bug.