Need to remove treechildren BEFORE quietly removing its children

VERIFIED FIXED

Status

()

Core
RDF
P3
critical
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: Brian Ryner (not reading), Assigned: Brian Ryner (not reading))

Tracking

Trunk
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

18 years ago
When removing all content from a tree, the template builder currently removes
all of the children of the <treechildren> directly, then removes and reinserts
the <treechildren> at the end so the tree will notice.  This causes the tree to
be in an inconsistent state during these removals, which can cause a crash with
my checkin to fix bug 42109.

If the treechildren was first removed, then the tree should correctly report
that it has 0 rows.
(Assignee)

Comment 1

18 years ago
rginda, it seems that my patch for this might fix the chatzilla problem you were
seeing.
(Assignee)

Comment 2

18 years ago
Created attachment 13634 [details] [diff] [review]
patch
(Assignee)

Comment 3

18 years ago
Created attachment 13638 [details] [diff] [review]
patch #2
(Assignee)

Comment 4

18 years ago
Attached a new patch waterson says should be better.

putterman, would you mind giving this a try and see if you can find any odd
behavior or problems?

Comment 5

18 years ago
This does indeed fix chatzilla.  Also, I checked out mailnews (created an IMAP
account, retrieved messages, read a few) and didn't notice any *new*
regressions.

Comment 6

18 years ago
bryner, didn't you fix this? If not, check in your patch, r=waterson.

Comment 7

18 years ago
giving bryner the glory
Assignee: waterson → bryner
(Assignee)

Comment 8

18 years ago
Marking dependency... this is also causing chatzilla crashes, although I don't
have the bug number for that.
Blocks: 47795
Status: NEW → ASSIGNED

Comment 9

18 years ago
*** Bug 49410 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Blocks: 47673
(Assignee)

Comment 10

18 years ago
Checked in a fix.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 11

18 years ago
yep, we do this in the right order now in the template builder.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.