Closed Bug 506019 Opened 11 years ago Closed 11 years ago

Default Theme: Messages Do Not Display in Separate Window

Categories

(SeaMonkey :: MailNews: Message Display, defect, major)

All
macOS
defect
Not set
major

Tracking

(Not tracked)

VERIFIED FIXED
seamonkey2.0b2

People

(Reporter: tommybee99, Assigned: mnyromyr)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.1pre) Gecko/20090718 SeaMonkey/2.0b1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.1pre) Gecko/20090718 SeaMonkey/2.0b1

I just updated from 2.0a3 to 2.0b1 on two separate machines, and on both I am unable to view IMAP message contents in a separate window (the preview pane works fine).  The message toolbar at the top appears, but the rest of the window is blank.  This problem does not appear to affect 2.0b1 on Windows Vista with SP2 -- only on Mac OS X Leopard (10.5.7).

Reproducible: Always

Steps to Reproduce:
1. Launch SeaMonkey.
2. Open the Mail/News component.
3. Double-click on a message in an IMAP mailbox.
Actual Results:  
The window appears with the toolbar at the top but no contents below it.

Expected Results:  
The window appears with the toolbar at the top, the message headers below it, and the message content in the remainder of the window.
Correction:  this affect both POP and IMAP (I couldn't check this on my work computer).
Summary: Messages in IMAP Account Do Not Display in Separate Window → Messages in Mail Account Do Not Display in Separate Window
Flags: blocking-seamonkey2.0b2?
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.2pre) Gecko/20090724 SeaMonkey/2.0b2pre also contains this bug, so it wasn't an anomaly to the 2.0b1 build.
Back to 2.0b1, I tried viewing messages with the Modern theme instead of the default theme, and the message windows worked properly.  Could this be an issue with the theme itself rather than the message display window?
Summary: Messages in Mail Account Do Not Display in Separate Window → Default Theme: Messages Do Not Display in Separate Window
Frank and Karsten are apparently investigating this - is this bug report a dupe or is it the one where we should get that patch in once we find it?

As a note: This is Mac only, Linux and Windows are not affected - we're not sure yet why that is though.
Duplicate of this bug: 506043
(In reply to comment #4)
> As a note: This is Mac only, Linux and Windows are not affected - we're not
> sure yet why that is though.

Seems to be some strange(?) behavior of XPCOM, calling addObserver (nsIPrefBranch2) on a nsIPrefBranch object in JS seems to work fine on Windows and Linux, but not on Mac.
The messenger window makes sure to cast the global pref var to nsIPrefBranch2 in msgMail3PaneWindow.js::OnLoadMessenger, but the messageWindow doesn't. Both do call the same function to initialize so pref, so we could just as well make it an nsIPrefBranch2 in the first place...

Patch written on Mac and tested under Linux.
Assignee: nobody → mnyromyr
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #390574 - Flags: superreview?
Attachment #390574 - Flags: review?
Attachment #390574 - Flags: superreview?(bugzilla)
Attachment #390574 - Flags: superreview?
Attachment #390574 - Flags: review?(bugzilla)
Attachment #390574 - Flags: review?
Hardware: x86 → All
Version: unspecified → Trunk
Flags: blocking-seamonkey2.0b2? → blocking-seamonkey2.0b2+
(In reply to comment #3)
> Back to 2.0b1, I tried viewing messages with the Modern theme instead of the
> default theme, and the message windows worked properly.  Could this be an issue
> with the theme itself rather than the message display window?
You've hit the nail on the head!

The Mac Classic theme uses its own grippytoolbar-drag binding rather than the old grippytoolbar-primary binding that we keep in order to honour the browser.chrome.toolbar_style preference. And it is this toolbar preference code that has the side effect of making the message window work...
Attachment #390574 - Flags: superreview?(bugzilla)
Attachment #390574 - Flags: superreview+
Attachment #390574 - Flags: review?(bugzilla)
Attachment #390574 - Flags: review+
Pushed as <http://hg.mozilla.org/comm-central/rev/ea57778deaea>.
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.0b2
Verified fixed in build 20090727002647; with the Mac Classic theme in use, message windows now display the headers and contents as expected.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.2pre) Gecko/20090727 SeaMonkey/2.0b2pre

Thanks for the quick turnaround!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.