save session dialog prevents system from gracefull shutdown or restart

RESOLVED WONTFIX

Status

()

Firefox
Session Restore
RESOLVED WONTFIX
9 years ago
8 years ago

People

(Reporter: Andrew Zschetzsche, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [wontfix?])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: 

When a user tells their system to shutdown or restart and Firefox is open in a state that will trigger the "Do you want Firefox to save your tabs for the next time it starts?" dialog, Firefox displays the dialog and waits for user input.  However, the system (Windows XP/Vista/7, and Mac OS X) reports that Firefox is not responding to the shutdown / restart request, and it causes the shutdown to be canceled on OS X, and Windows will ask you to force quit Firefox.  In such a situation, it is reasonable to conclude that the user wants to quickly shutdown or restart the system and is no longer interested in interacting with Firefox.  Therefore, I propose that on a Shutdown or Restart request from the system trigger Firefox to save the session and then exit without user intervention.

Reproducible: Always

Steps to Reproduce:
1. Load Firefox and open a few tabs.
2. Tell Windows or Mac OS X to shutdown or restart.
3. Wait.
Actual Results:  
The system shutdown or restart will be canceled on OS X, and Windows will ask you to Force Quit Firefox.

Expected Results:  
Saved the current session and terminate the program, allowing the shutdown or restart to continue.

This happens on all versions of Windows and all versions of Mac OS X.  Linux (tested on Ubuntu 9.04) appears to simply kill the window server instead.  I find this bug extremely annoying, especially when it could easily save the session automatically.  However, I still want to be asked to save or quit when I manually exit Firefox.

Comment 1

9 years ago
There is no way of knowing if the user hasn't accidentally forgotten about that minimized Firefox session containing data that our SessionStore can't or won't restore (such as plugin data or https forms), so we do what most other programs do in the same situation as well: ask if the user is OK with losing her data.

And there's a privacy angle to it as well: you could just as well forget about a session containing pages you wouldn't want to accidentally popup in front of anybody else when you start Firefox tomorrow.

Both of these arguments make this bug most likely WONTFIX.
Whiteboard: [wontfix?]
I tend to agree with both arguments made in comment 1.  Since no one has risen up in outrage or counter argument in well over 6 months, I'm resolving WONTFIX.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
Duplicate of this bug: 561175
You need to log in before you can comment on or make changes to this bug.