Need more faster fix for x86 evict bug 465484

REOPENED
Assigned to

Status

P4
normal
REOPENED
9 years ago
7 years ago

People

(Reporter: rreitmai, Assigned: wmaddox)

Tracking

unspecified
Future
x86
All
Dependency tree / graph
Bug Flags:
in-testsuite +
flashplayer-qrb +
flashplayer-triage +

Details

(Whiteboard: PACMAN)

(Reporter)

Description

9 years ago
The fix outlined in bug 465484 causes a performance regression for tamarin in misc/primes

Comment 1

9 years ago
- sending to qrb for target milestone, this is marked as a blocker for the TM/TR nanojit merge so needs to be targeted from this release
- will be able to track perf change using mentioned performance micro benchmark:

test/performance/misc/primes.as
Flags: in-testsuite+
Flags: flashplayer-triage+
Flags: flashplayer-qrb?

Updated

9 years ago
Assignee: nobody → rreitmai
Status: NEW → ASSIGNED
Flags: flashplayer-qrb? → flashplayer-qrb+
Priority: -- → P2
Target Milestone: --- → flash10.1
(Reporter)

Updated

9 years ago
Summary: Need to come up with a better fix for bug 465484 → Need to come up with a better fix for x86 evict bug 465484

Comment 2

9 years ago
(In reply to comment #0)
> The fix outlined in bug 465484 causes a performance regression for tamarin in
> misc/primes

...but surely only on non-SSE2 machines, right?
(Reporter)

Updated

9 years ago
Summary: Need to come up with a better fix for x86 evict bug 465484 → TM merge: Need to come up with a better fix for x86 evict bug 465484

Updated

9 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 491084
(Reporter)

Updated

9 years ago
Depends on: 491084
(Reporter)

Updated

9 years ago
No longer depends on: 491084

Updated

9 years ago
Status: RESOLVED → VERIFIED

Comment 4

9 years ago
re-opening to track the work of improving the good-enough fix that is in place now.  The existing fix causes a 5% slowdown in misc/primes.as, but negligible slowdown in the rest of the tests.
No longer blocks: 503556
Status: VERIFIED → REOPENED
Priority: P2 → P3
Resolution: DUPLICATE → ---
(Reporter)

Updated

9 years ago
Blocks: 526914
(Reporter)

Comment 5

9 years ago
un-assigning
Assignee: rreitmai → nobody

Updated

9 years ago
Priority: P3 → P4

Updated

9 years ago
Target Milestone: flash10.1 → flash10.2

Comment 6

8 years ago
this is probably low hanging fruit for x86
Whiteboard: PACMAN
(Assignee)

Updated

8 years ago
Assignee: nobody → wmaddox

Updated

8 years ago
Depends on: 641055

Updated

7 years ago
Target Milestone: Q3 11 - Serrano → Q4 11 - Anza

Comment 7

7 years ago
Retargeting to Future.
Summary: TM merge: Need to come up with a better fix for x86 evict bug 465484 → Need more faster fix for x86 evict bug 465484
Target Milestone: Q4 11 - Anza → Future

Comment 8

7 years ago
Removing Andre blocker, as Dan assigned it two future.
No longer depends on: 641055
You need to log in before you can comment on or make changes to this bug.