Closed Bug 506322 Opened 11 years ago Closed 10 years ago

Today pane collapse/expand buttons should always react to first click

Categories

(Calendar :: General, defect, minor)

defect
Not set
minor

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: merike, Assigned: Fallen)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; et; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)
Build Identifier: 

After focusing on an event in today pane collapse button needs to clicks to work.

Reproducible: Always

Steps to Reproduce:
1. Create an event on tomorrow
2. Make sure tomorrow section is expanded
3. Click on the event in today pane and hit delete
4. Click on collapse button

Actual Results:  
It won't collapse.

Expected Results:  
It should collapse.

A second click on collapse button makes it collapse.
Confirmed, since Clint could reproduce this as noted in the calendar mozmill bug. It would be nice to fix this since there is a mozmill test that uses this feature.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: wanted-calendar1.0+
Attached patch Fix - v1Splinter Review
Hmm strange stuff. The items were being disabled. This caused clicks to not toggle the checked state correctly. Does anyone know why we needed to disable those items on blur?
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Attachment #398873 - Flags: review?(mschroeder)
Comment on attachment 398873 [details] [diff] [review]
Fix - v1

r=mschroeder, and I don't know the reason for disabling the items on blur, but Berend should!
Attachment #398873 - Flags: review?(mschroeder) → review+
I'll ask Berend tomorrow.

Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/1ebe58064c88>

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0
Berend told me this was a UI decision: when the focus is not on the today pane, the today pane items should not have the selected color. With the patch above, this is reverted.

What we could do is try to use css rules with the :focus pseudo-selector to make sure it looks normal when not focused, but I think this is also a more general problem we shouldn't start fixing in calendar. For example, the folder pane also remains in the selected color when not focused.
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.