I am about to start work on SeaMonkey Bug 16908 which changes the New Message button into a menu-button. It looks like this won't interfere with the overlay in messenger-overlay-toolbar.xul. However I would like to change the id of the menupopup from "button-newmsg-menupopup" to "button-newMsgPopup" to follow the current naming conventions in both Thunderbird and SeaMonkey MailNews. As far as I can tell from MXR, nothing depends on this particular id.
Created attachment 390647 [details] [diff] [review] Patch v1.0 "button-newmsg-menupopup" -> "button-newMsgPopup"
Attachment #390647 - Flags: review?(philipp)
Attachment #390647 - Flags: review?(philipp) → review+
Comment on attachment 390647 [details] [diff] [review] Patch v1.0 Concerns I'd have with this is that someone might likely change this when aligning id style in the future. We haven't really agreed on an id style in Calendar, but we have been using the dash separated style quite often. Maybe you can add a comment in this specific case, at some point we should align all ids to something as common as possible. r=philipp with comment added.
Created attachment 390779 [details] [diff] [review] Patch v1.1 (Comment nit fixed) r=philipp Carrying forward r+ from philipp. > Maybe you can add a comment in this specific case Fixed.
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/3c14886af64c> -> FIXED
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0
You need to log in before you can comment on or make changes to this bug.