3.5.1 Session Restore universal failure

RESOLVED WORKSFORME

Status

()

Firefox
Session Restore
--
major
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: joshuase, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 2.0.50727; .NET CLR 3.0.30618; .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 2.0.50727; .NET CLR 3.0.30618; .NET CLR 3.5.30729)

After installing 3.5 I configured it to:

Open windows and tabs from last time
Use custom settings for history
Not automatically start in a private browsing session
Remember my browsing history for at least 5 days
and not clear browsing history when closing

I then immediately closed it, and upon reopening it my homepage was returned.

I am concerned after seeing that many reports like this were labeled as duplicates of drastically different reportsand a similar problem ignored in 1.0.8, I hope this will be read carefully.

Reproducible: Always

Steps to Reproduce:
1.Adjust settings as described
2.Open a tab or two
3.restart Firefox 3.5.
Actual Results:  
Homepage

Expected Results:  
Some tabs

There is a very slight chance that my laptop's substandard construction is at fault, it has also refused to ever compile anything.
I don't have Vista handy to test, but this works for me as expected here on my Mac. Can you maybe try with a new profile to see if you can reproduce with the settings you described?
(Reporter)

Comment 2

9 years ago
That worked, and come to tthink of it a number of other things don't work normally but work in a new profile. I'll remember to check before reporting new bugs.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.