Closed Bug 506588 Opened 10 years ago Closed 10 years ago

Increasingly frequent Server Not Found in Firefox 3.5 with Netgear Router

Categories

(Firefox :: General, defect, major)

x86
Windows XP
defect
Not set
major

Tracking

()

VERIFIED DUPLICATE of bug 475603

People

(Reporter: goleynik, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.12) Gecko/2009070611 Firefox/3.0.12 (.NET CLR 3.5.30729)
Build Identifier: This is about firefox 3.5 - I had to deinstall and have 3.0.12 as workaround

Increasingly I was getting "server not found" errors when trying to navigate to pages. Trying again or several times wiould eventually get to the page but it is maddening. In addition, the 3.5 install also results in Internet explorer having the same problem. I searched the Web and found many people are having this problem when updating to Firefox 3.5 and the only fix was a deinstall. Rolling back to Firefox 3.0.11 or 3.0.12 fixes the problem for both Firefox and Internet explorer. 

Apparently this is related to wireless routers and dns caching. This problem seems to appear particularly with Netgear routers (which I have), but is not limited to them. Some people connected wired to their router, the problem went away. 

Reproducible: Sometimes

Steps to Reproduce:
1.Use an older netgear wireless router and connect by XP system with Firefox 3.5
2.Use the browser for some time. the frequency of the Server Not Found increase with time
3.



A lot of people are experiencing this problem and I am sure a lot more don't even realize it is a Mozilla Firefox problem. This puts them in a precarious position as they must roll back to 3.0.xx or abandon Firefox.
>I am sure a lot more don't even realize it is a Mozilla Firefox problem.
If it's the issue that I think it is then it is not a Firefox problem.
It's a broken router DNS forwarder triggered by more DNS requests as usual caused by Firefox DNS prefetching. The Windows DNS function that is used by nearly all applications including Firefox is caching DNS request and that includes the broken router answer,use "ipconfig /flushdns" to clear the cache

Please open about:config, confirm the warning, create (!) a new boolean pref
with network.dns.disablePrefetch=true to disable the DNS prefetching for a test if my theory is correct.
I have tried what you suggested - reinstalled 3.5.1 and disabled the prefetch in the config and it does not help. All I have to do is search for "Server not Found firefox 3.5" and start clicking through the links and pretty soon loads start to slow and then  "server Not Found" errors start occurring. Clicking on retry one to several times will load the page eventually.

A reason I do not think this is a router problem is that Internet Explorer works fine until Firefox 3.5.x is loaded, then it starts failing to load pages. 

Uninstalling back to 3.0.11 or 3.0.12 and everything works again.

It is not just a Netgear router. there are reports of ADSL routers and other types of wireless routers. Here are some links:

http://support.mozilla.com/tiki-view_forum_thread.php?locale=en-US&forumId=1&comments_parentId=396986

http://forum1.netgear.com/showthread.php?t=39270

http://support.mozilla.com/tiki-view_forum_thread.php?locale=fr&forumId=1&comments_parentId=381737

Back to 3.0.12

Gene Oleynik
>A reason I do not think this is a router problem is that Internet Explorer
>works fine until Firefox 3.5.x is loaded, then it starts failing to load pages. 

Firefox doesn't change any system files or settings !
You can get Firefox as Zip build, extract the zip to a directory and run Firefox without installing it. The installer only writes a registry key with Firefox installation dire3ctory for other software like plugins and it adds registry keys for the default browser in the OS, nothing more.
That means that installing Firefox can not change anything related to DNS resolving in the OS. I assume you use Firefox and after that try the same address with IE. That IE fails to resolve the same DNS names is is a sign that this is a router issue and this bug is a dupe of bug 475603.

If this is a bug in the DNS forwarder daemon on the router it can affect more than one router and not only netgear routers.
I have done the following:

1. Reinstalled 3.5.1
2. Turned off the dns prefetching in Firefox
3. Reset the NETGEAR wireless router

I have used this for several days now and haven't run across any unexpected server not found lookups.
Thanks, I will mark this as dupe of bug 475603
I think that if we get enough dupes the developers have to think about adding a workaround for such broken routers.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 475603
It's not in our hands to fix broken software on their end. As my tests on bug 475603 has been shown all applications and the OS itself is affected. We really should try to get a word to Netgear.
Status: RESOLVED → VERIFIED
Summary: Increasingly frequent Server Not Found in Firefox 3.5 → Increasingly frequent Server Not Found in Firefox 3.5 with Netgear Router
Henrik:
Not only Netgear is affected, THere are AFAIK reports about Netgear, Seemens, Cisco.
You need to log in before you can comment on or make changes to this bug.