View, task list, and toolbar broken after startup [Error: "composite is not defined"]

VERIFIED FIXED in 1.0b1

Status

Calendar
General
--
major
VERIFIED FIXED
9 years ago
7 years ago

People

(Reporter: ssitter, Assigned: Fallen)

Tracking

({regression})

Trunk
1.0b1
regression
Dependency tree / graph
Bug Flags:
blocking-calendar1.0 +

Details

(Whiteboard: [needed beta][no l10n impact])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

9 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2pre) Gecko/20090726 Calendar/1.0pre (BuildID: 20090726032236)

Steps to Reproduce:
===================
1. Start Sunbird with new or existing profile

Actual Results:
===============
Main calendar view is garbled, task list is empty, toolbar buttons are not enabled. Error console shows:

Error: composite is not defined
Source File: chrome://calendar/content/calendar-task-tree.xml Line: 942

Error: [Exception... "'[JavaScript Error: "composite is not defined" {file: "chrome://calendar/content/calendar-task-tree.xml" line: 943}]' when calling method: [calICompositeObserver::onCalendarAdded]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: file:///E:/sunbird/calendar-js/calUtils.js :: notifyFunc :: line 1221"  data: yes] STACK: 
1: [file:///E:/sunbird/calendar-js/calUtils.js:1224] notifyFunc
2: [file:///E:/sunbird/calendar-js/calUtils.js:1227] calListenerBag_notify
3: [file:///E:/sunbird/components/calCompositeCalendar.js:209] cCC_addCalendar
4: [null:0] null
5: [chrome://calendar/content/widgets/calendar-list-tree.xml:109] cMO_onCalendarRegistered
6: [null:0] null
7: [file:///E:/sunbird/calendar-js/calUtils.js:1221] notifyFunc
8: [file:///E:/sunbird/calendar-js/calUtils.js:1227] calListenerBag_notify
9: [file:///E:/sunbird/calendar-js/calCalendarManager.js:598] anonymous
10: [file:///E:/sunbird/calendar-js/calCalendarManager.js:666] anonymous
Source File: file:///E:/sunbird/calendar-js/calUtils.js Line: 1224
(Reporter)

Comment 1

9 years ago
Regression range: Works in Sunbird 1.0pre (BuildID: 20090724050954)
                  Fails in Sunbird 1.0pre (BuildID: 20090725052505)

Checkins during regression range: https://hg.mozilla.org/comm-central/pushloghtml?startdate=2009-07-24+05:09:54&enddate=2009-07-25+05:25:05

Seems to be caused by the checkin for Bug 500718.
(Reporter)

Updated

9 years ago
Blocks: 500718
(Reporter)

Comment 2

9 years ago
Error message can be observed too using Lightning 1.0pre (BuildID: 20090726050415) with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2pre) Gecko/20090725 Shredder/3.0b4pre.
Flags: blocking-calendar1.0+
Created attachment 390783 [details] [diff] [review]
Patch v1

This should fix the problem. But maybe there are some changes missing in the function 'refreshFromCalendar' that get rid of using the composite calendar?
Philipp and Wolfgang, can you have a look at this issue?
Hopefully Merike's tests will prevent such bugs in the future.
(Assignee)

Comment 6

9 years ago
Created attachment 390823 [details] [diff] [review]
Fix - v2

I believe we should rather be refreshing only the passed calendar, but I'll leave this to Wolfgang to review.
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Attachment #390823 - Flags: review?
(Assignee)

Updated

9 years ago
Attachment #390823 - Flags: review? → review?(WSourdeau)
OS: Windows XP → All
Hardware: x86 → All
(Assignee)

Updated

9 years ago
Whiteboard: [needed beta][no l10n impact]
(Reporter)

Updated

9 years ago
Blocks: 506950
(Reporter)

Comment 7

9 years ago
Comment on attachment 390823 [details] [diff] [review]
Fix - v2

r=ssitter for the bustage fix.

With the patch applied the task list still updates incorrectly when adding, removing, disabling, or enabling calendars but that could be covered in a follow-up bug.
Attachment #390823 - Flags: review+
(Assignee)

Updated

9 years ago
Duplicate of this bug: 506950
(Assignee)

Comment 9

9 years ago
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/9cb340898f50>

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0
(Assignee)

Comment 10

9 years ago
Followup bug is bug 507105.
(Assignee)

Updated

9 years ago
Attachment #390823 - Flags: review?(WSourdeau)
Attachment #390783 - Attachment is obsolete: true

Comment 11

8 years ago
verified with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.9pre) Gecko/20100313 Calendar/1.0b2pre
Status: RESOLVED → VERIFIED
(Assignee)

Comment 12

7 years ago
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.