Arrowing down to an item in autocomplete doesn't show item's URL in location bar if the string match was based on page title

RESOLVED WONTFIX

Status

defect
RESOLVED WONTFIX
10 years ago
2 years ago

People

(Reporter: mehmet.sahin, Unassigned)

Tracking

Trunk
x86
macOS

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en; rv:1.9.0.13pre) Gecko/2009072700 Camino/2.1a1pre (like Firefox/3.0.13pre)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en; rv:1.9.0.13pre) Gecko/2009072700 Camino/2.1a1pre (like Firefox/3.0.13pre)

Hello Camino-Team,

I found a bug in the new autocomplete-bar when URL is selected from the title.

***see steps to reproduce***

Thanks & regards
Mehmet

Reproducible: Always

Steps to Reproduce:
1. go to: http://forums.mozillazine.org/viewforum.php?f=12
2. Now, type for example the letter "c" into the url-bar
3. Autocomplete window opens and show results
4. go (with tab or arrow down) to the bookmark which contains the title beginning with the letter "c" (in my example the title is = Camino - mozillaZine Forums)
Actual Results:  
The Url "forums.mozillazine.org/viewforum.php?f=12" is not shown in the URL bar. 

Expected Results:  
The Url "forums.mozillazine.org/viewforum.php?f=12" should be shown in the URL bar.
(Reporter)

Comment 1

10 years ago
Posted image hardcopy of the bug
(Reporter)

Updated

10 years ago
Summary: Autocomplete from title don't show the URL in the URL-Bar → Autocomplete from title don't show the URL in the URL-Bar (Camino 2.1)
Version: unspecified → Trunk

Comment 2

10 years ago
We'll have to figure out how to handle this case; It's not clear that stomping the text that the user has entered so far is the correct behavior, since it breaks the ability to refine the search.

Also, for future reference, please don't attach screenshots unless they provide information that the description/STR of the bug doesn't.
(Reporter)

Comment 3

9 years ago
> Steps to Reproduce:
> 1. go to: http://forums.mozillazine.org/viewforum.php?f=12
> 2. Now, type for example the letter "c" into the url-bar
> 3. Autocomplete window opens and show results
> 4. go (with tab or arrow down) to the bookmark which contains the title
> beginning with the letter "c" (in my example the title is = Camino -
> mozillaZine Forums)
> Actual Results:  
> The Url "forums.mozillazine.org/viewforum.php?f=12" is not shown in the URL
> bar. 
> 
> Expected Results:  
> The Url "forums.mozillazine.org/viewforum.php?f=12" should be shown in the URL
> bar.

Oh, I'm sorry for the wrong AR/ER! In this case the TITLE of the Bookmark should be to see, of course. (Like in Safari 5 now.) The URL should be only seen after pressing ENTER.

Thanks and regards
Mehmet
I find the Safari 5 UI very, very busy and distracting/annoying, although it does address the bug described here ;)
A side effect of this bug is that Cmd-Return on something will give different results from Return, and from what the user might expect.

STR -(with a default profile)

1. load http://www.talkingpointsmemo.com/ (title contains 'Talking Points Memo', url contains 'me')
2. load http://www.jma.go.jp/en/yoho/ (title contains Japan Meteorological Agency)

3. go somewhere else, just building a little bit of history
4. type 'me' in the location bar
5. select (arrow down) one of the two entries visited in [1] or [2]
6. press Return

AR: you go to the selected website -- OK

5a. select (arrow down) one of the two entries visited in [1] or [2]
6a. press Cmd-Return

AR:
- arrow down, the url bar shows 'memo.com/' for talkingpointsmemo.com/
  Cmd-Return brings up some completely different location.
- arrow down, the url bar still shows 'me' for jma.go.jp/en/yoho/ 
  Cmd-Return brings up 'me.com'

--

[08:48am] sauron: we don't get the url as "input" for Cmd-Return
[08:49am] sauron: Cmd-Return acts on the contents of the location bar
[08:49am] sauron: which are "me.com" and "memo.com"
[08:50am] sauron: er, "me" and "memo.com"
(Reporter)

Comment 6

9 years ago
@philippe: Yes, I can confirm this!

But maybe my report was not clear reported and is misunderstanding. What I mean is the following:

Visit the following two sites:

1.) http://wiki.caminobrowser.org/Main_Page
2.) http://stadt-bremerhaven.de/ (Title is: "Caschys Blog - Software und jede Menge Tipps & Tricks")

3.) Now, type "ca" into the Location-Bar.
--> Result: You see both visited sites in the Location-Bar-History-List.

4.) Now arrow-down to "wiki.caminobrowser.org"
--> Result: You see "caminobrowser.org" autocompleted in the Location-Bar, because "ca" is matched from the "URL".

5.) Now arrow-down to "stadt-bremerhaven.de"
--> Result: You see still "caminobrowser.org" in the Location-Bar.
--> But there should be "caschys Blog - Software und jede Menge Tipps & Tricks" to see in the Location-Bar, because "ca" is matched from the "title"

--> The Problem here is, that when a string is matched from "title" (not from the "URL") then it is not updated and to see in the Location-Bar.

Thanks!
Now that we've landed the latest autocomplete fixes, can you try this with the current nightly and let us know what, if anything, still needs to be addressed here?
(Reporter)

Comment 8

8 years ago
Hi Chris,

the bug (see comment 6) is still present in the latest build. Please let me know, if you need more infos!!!

Camino Version 2.1a1pre (1.9.2.14pre 20110106000736).
[4:35pm] smorgan: Maybe I'm confused about the bug
[4:36pm] smorgan: Oh, you have to arrow down to it
[4:36pm] smorgan: Chrome does stomp in that case
[4:36pm] smorgan: Yeah, I guess confirm it
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Autocomplete from title don't show the URL in the URL-Bar (Camino 2.1) → Arrowing down to an item in autocomplete doesn't show item's URL in location bar if the string match was based on page title
Mehmet: Now that I know what to look for, I see what you're talking about (and what Philippe mentioned in comment 5). I ran into it earlier tonight myself.
(Reporter)

Comment 11

2 years ago
Camino is no longer supported. Closing my old bug report.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.