[HTML5] Crash while running local mochitest-plain in test_foreign.html [@ nsHtml5TreeBuilder::popOnEof]

VERIFIED WORKSFORME

Status

()

Core
HTML: Parser
P1
critical
VERIFIED WORKSFORME
9 years ago
7 years ago

People

(Reporter: Natch, Unassigned)

Tracking

({crash})

Trunk
x86
Windows Vista
crash
Points:
---
Bug Flags:
blocking1.9.2 -
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Created attachment 390998 [details]
windbg session

This is with html5 on, stack attached.
Flags: in-testsuite+
Flags: blocking1.9.2?
(Reporter)

Comment 1

9 years ago
Maybe a dupe of bug 502973, but this crash seems to be a bit different, so not sure...

Comment 2

9 years ago
HTML5 is off by default with no UI to turn it on, not a blocker.
Flags: blocking1.9.2? → blocking1.9.2-
(Reporter)

Updated

9 years ago
Depends on: 502973
(Reporter)

Comment 3

9 years ago
Can't reproduce anymore.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
No longer depends on: 502973
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

8 years ago
Happening again now, only with the pref on.
Status: RESOLVED → REOPENED
blocking2.0: --- → ?
Resolution: WORKSFORME → ---
Summary: Crash while running local mochitest-plain in test_foreign.html [@ nsHtml5TreeBuilder::popOnEof] → [HTML5] Crash while running local mochitest-plain in test_foreign.html [@ nsHtml5TreeBuilder::popOnEof]
Priority: -- → P2
I don't see the crash on Mac running 
TEST_PATH=dom/tests/mochitest/ajax/offline/test_foreign.html make -C obj-ff mochitest-plain
with the pref patched on.
Resolving as WFM. Please reopen if the problem persists.
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago8 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

8 years ago
Doesn't crash anymore, just fails...

v.
Status: RESOLVED → VERIFIED
blocking2.0: ? → ---
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsHtml5TreeBuilder::popOnEof]
You need to log in before you can comment on or make changes to this bug.