TD ROWSPAN miscalculates lower boundary for CELLSPACING > 0

VERIFIED DUPLICATE of bug 2267

Status

()

Core
Layout: Tables
P3
normal
VERIFIED DUPLICATE of bug 2267
19 years ago
11 years ago

People

(Reporter: John Morrison, Assigned: karnaze (gone))

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Not to add to the list, but I haven't seen this explicity stated under any
other bug reports (although it could well affect other rowspan-related bugs0.

<html><body>
  <table border cellpadding=0 cellspacing=15>
    <tr>
      <td rowspan=2>1,1</td>
      <td>1,2</td>
    </tr>
    <tr>
      <td>2,2</td>
    </tr>
  </table>
</body></html>

For Apr 9 & 11 viewer.exe Win95 opt, this simple case results
in the lower boundary of the 1,1 ROWSPAN cell extending lower than it
should. i.e., it appears to add (rather than subtract) the cellspacing
to it's base boundary. The cellspacing=15 simply makes this
error more visible; it exaggerates the error; it occurs for cellspacing > 0,
but it is only faintly noticeable at cellspacing ~ 1. It occurs in other uses of
(ROWSPAN > 1), but this is the base case.
(Reporter)

Comment 1

19 years ago
Created attachment 17 [details]
test case; ROWSPAN cell miscalculates lower boundary
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 2

19 years ago
*** This bug has been marked as a duplicate of 2267 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 3

19 years ago
Verified this bug a duplicate of #2267 in regards to the rowspan problem.
You need to log in before you can comment on or make changes to this bug.