Closed Bug 506966 Opened 12 years ago Closed 11 years ago

NSS does not support CKR_PIN_LOCKED from C_Login

Categories

(NSS :: Libraries, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
3.12.7

People

(Reporter: martin, Assigned: rrelyea)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_7; et-ee) AppleWebKit/530.19.2 (KHTML, like Gecko) Version/4.0.2 Safari/530.19
Build Identifier: 

NSS translates CKR_PIN_LOCKED to a generic NSS return code for Firefox and Firefox can not react on the locked state. A new return code should be returned so that Firefox could display a information window.

Reproducible: Always
Blocks: 506939
Bob, I suggested this RFE.  
It certainly is reasonable for an application to stop asking for a password
and instead say "you cannot login to this token because it is locked".
Assignee: nobody → rrelyea
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → trunk
This is clearly a pre-req for Firefox do present some useful message in this as well.

bob
We need this as well for our use of NSS. Attached is a patch that makes sure the error code is propagated back to the app.
Comment on attachment 412200 [details] [diff] [review]
nss-3.12.4-pk11locked.patch

Bob should probably review this patch, and a NSS engineer should check it in (if r+'ed)
Attachment #412200 - Flags: review?(rrelyea)
Comment on attachment 412200 [details] [diff] [review]
nss-3.12.4-pk11locked.patch

r+ rrelyea
Attachment #412200 - Flags: review?(rrelyea) → review+
thanks for your contribution, checked in


Checking in pk11wrap/pk11err.c;
/cvsroot/mozilla/security/nss/lib/pk11wrap/pk11err.c,v  <--  pk11err.c
new revision: 1.11; previous revision: 1.10
done
Checking in util/secerr.h;
/cvsroot/mozilla/security/nss/lib/util/secerr.h,v  <--  secerr.h
new revision: 1.26; previous revision: 1.25
done
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → 3.12.7
You need to log in before you can comment on or make changes to this bug.