Closed Bug 507239 Opened 11 years ago Closed 9 years ago

random failure in test_395593.js

Categories

(Toolkit :: Places, defect)

defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: mak, Unassigned)

References

Details

(Keywords: intermittent-failure, Whiteboard: [workarounded by bug521225 on trunk])

Attachments

(1 file)

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1248894006.1248901389.9525.gz

TEST-UNEXPECTED-FAIL | /builds/slave/mozilla-central-linux-unittest/build/objdir/_tests/xpcshell/test_places/bookmarks/test_395593.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | /builds/slave/mozilla-central-linux-unittest/build/objdir/_tests/xpcshell/test_places/bookmarks/test_395593.js | 1 == 3 - See following stack:
JS frame :: /builds/slave/mozilla-central-linux-unittest/build/testing/xpcshell/head.js :: do_throw :: line 187
JS frame :: /builds/slave/mozilla-central-linux-unittest/build/testing/xpcshell/head.js :: do_check_eq :: line 217
JS frame :: /builds/slave/mozilla-central-linux-unittest/build/objdir/_tests/xpcshell/test_places/bookmarks/test_395593.js :: run_test :: line 84
JS frame :: /builds/slave/mozilla-central-linux-unittest/build/testing/xpcshell/head.js :: _execute_test :: line 126
Blocks: 438871
Whiteboard: [orange]
Attached patch add some loggingSplinter Review
i can't see a reason for the failure, it is like only one of the 2 queries is returning results, but i can't reproduce any failure even running the test in loop for tens of times.

This just adds some more dump, so that if it fails again we will know which results it is returning.
Attachment #392076 - Flags: review?(dietrich)
Attachment #392076 - Flags: review?(dietrich) → review+
Depends on: 507790
Depends on: 521225
Whiteboard: [orange] → [orange][workarounded by bug521225 on trunk]
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6/1267539884.1267540511.21838.gz
Linux mozilla-1.9.2 opt test xpcshell on 2010/03/02 06:24:44
s: mv-moz2-linux-ix-slave06
Resolving Places oranges that don't appear on central from at least 6 months.
Check dependencies for bugs that could have fixed the issue.
Please reopen if they re-appear in central.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Whiteboard: [orange][workarounded by bug521225 on trunk] → [workarounded by bug521225 on trunk]
You need to log in before you can comment on or make changes to this bug.