The mail filter based on body content seems not working with base64 encoded mails

VERIFIED DUPLICATE of bug 132340

Status

MailNews Core
Filters
VERIFIED DUPLICATE of bug 132340
9 years ago
9 years ago

People

(Reporter: Federico De Faveri, Unassigned)

Tracking

1.8 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.12) Gecko/2009070811 Ubuntu/9.04 (jaunty) Firefox/3.0.12
Build Identifier: version 2.0.0.22 (20090608)

I'm trying to filter some mails with rules based on body content but this seems not working. The mail is base64 encoded.

Reproducible: Always

Steps to Reproduce:
1.add a new filter rule with body contains "text"
2.apply this to a folder contains mails base64 encoded and with "text" word in the body
Actual Results:  
No actions by the filter

Expected Results:  
Action by the filter.
Frederico are you requesting the same thing as in bug 105169 ?
(Reporter)

Comment 2

9 years ago
Not, I'm not talking about attachment.
The mail that I'm trying to filter have this header (Looking at the message source):

Content-transfer-encoding: base64

and the body is base64 coded.
Component: General → Filters
Product: Thunderbird → MailNews Core
QA Contact: general → filters
Version: unspecified → 1.8 Branch

Comment 3

9 years ago
does this work for you in tb 3.0 b3? I think this was fixed on the trunk a while ago.
(Reporter)

Comment 4

9 years ago
I'm using tb 2.0.0.22 (20090608). Do you thing the bug has been fixed on tb3?
(In reply to comment #4)
> I'm using tb 2.0.0.22 (20090608). Do you thing the bug has been fixed on tb3?

David think's so. Could you backup your profile as explained at http://www.mozilla.org/support/thunderbird/profile#backup - install Thunderbird 3.0b3 from http://www.mozillamessaging.com/en-US/thunderbird/early_releases/downloads/ try your filter - tell us if it works, and then decide which version of TB you want to continue using.
(Reporter)

Comment 6

9 years ago
OK, I just tryed it and seems working.

Thanks guys.

Bye
Federico

Comment 7

9 years ago
marking dup.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 132340
V.Duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.