Long hang on shutdown of places branch browser

RESOLVED WORKSFORME

Status

()

Toolkit
Places
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: Joe Drew (not getting mail), Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---
Bug Flags:
blocking1.9.2 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
When I quit my browser, I get a long hang (~25s) in shutdown while Firefox does some work. Here is a shark profile for that hang.
(Reporter)

Comment 1

9 years ago
Created attachment 391718 [details]
shark profile of shutdown hang
I see something like this (20+ second hangs on shutdown) all the time with my testing profile, especially if anything else disk or CPU intensive is going on in parallel.  Profiles suggest disk i/o and ExpireHistoryParanoid.

Anything I can provide here that would help with debugging this?
Flags: blocking1.9.2?
This bug is filed against the places branch builds, specifically, and won't block Firefox 3.6.

It seems like bug 407981 is simliar/related for release builds?
Flags: blocking1.9.2? → blocking1.9.2-
(In reply to comment #4)
> Bug 407981 isn't what I'm seeing.  I guess I'll file.
I think you are seeing the same bug.  It's all caused by expiration on shutdown (which we've had since Firefox 3.0).
One difference is that my window is still there, but I guess if we're expiring sync off my Cmd-Q it might be a similar issue...
are you still seeing this now that async expiration is landed? please close if not.
Reopen if you can reproduce in Firefox 4 and mail us a database to test.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.